summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaley Clark2015-12-12 04:05:13 -0800
committerHaley Clark2015-12-12 04:05:13 -0800
commitc7d29b742546111759bc46a83126d3cb9b668f38 (patch)
tree2661868c0dff7e69fdcbcbc9799c4562222dac83
downloadaur-plastimatch-static.tar.gz
Version 1.6.2. Initial packaging.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d600822ce9dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Dec 12 12:03:56 UTC 2015
+pkgbase = plastimatch-static
+ pkgdesc = Tools for medical image reconstruction and registration.
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = http://plastimatch.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = insight-toolkit
+ depends = dcmtk
+ depends = libpng
+ depends = zlib
+ depends = libtiff
+ depends = libjpeg-turbo
+ depends = fftw
+ depends = nlopt
+ optdepends = cuda
+ conflicts = plastimatch
+ source = http://forge.abcd.harvard.edu/gf/download/frsrelease/214/3443/plastimatch-1.6.2-Source.tar.bz2
+ md5sums = e2767664856b0ebfa4302528b94f3773
+ sha1sums = 38b7c11e24cb3bbeceab966f625ae0337c7fd725
+
+pkgname = plastimatch-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec33dba1c5b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Packaged by hal clark --> gmail.com@hdeanclark
+
+pkgname=plastimatch-static
+pkgver=1.6.2
+pkgrel=1
+pkgdesc='Tools for medical image reconstruction and registration.'
+arch=('i686' 'x86_64')
+url='http://plastimatch.org/'
+license=('BSD')
+conflicts=('plastimatch')
+depends=('insight-toolkit' 'dcmtk' 'libpng' 'zlib' 'libtiff' 'libjpeg-turbo' 'fftw' 'nlopt')
+makedepends=('cmake')
+optdepends=('cuda')
+
+source=("http://forge.abcd.harvard.edu/gf/download/frsrelease/214/3443/plastimatch-${pkgver}-Source.tar.bz2")
+md5sums=('e2767664856b0ebfa4302528b94f3773')
+sha1sums=('38b7c11e24cb3bbeceab966f625ae0337c7fd725')
+
+build() {
+ cd "${srcdir}"
+ rm -rf build
+ mkdir build
+ cd build
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DBUILD_TESTING:BOOL=off \
+ -DBUILD_SHARED_LIBS:BOOL=off \
+ ../plastimatch-${pkgver}-Source/
+
+ make
+}
+
+package() {
+ cd "${srcdir}"/build/
+ make DESTDIR="${pkgdir}" install
+}
+