summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-04-08 18:59:29 +0200
committerFabioLolix2023-04-08 18:59:29 +0200
commit29e01c303b1d29391b0a5e30dd2febe243b41907 (patch)
treeb078f05bb0b6f46609692f8ecfeacbcfb94accd4
parent9537a8b68dabfed8197ad5b8c5850b49398f2834 (diff)
downloadaur-play-emu-git.tar.gz
revision
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4409b1ba0453..933ee0628ef7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = play-emu-git
pkgdesc = Play! is an experimental Playstation 2 emulator.
- pkgver = 0.42.r60.gf7acc8d7
- pkgrel = 1
+ pkgver = 0.59.r52.g8e1cc18b
+ pkgrel = 2
url = https://purei.org/
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
makedepends = ninja
- makedepends = qt5-x11extras
+ makedepends = nlohmann-json
depends = qt5-base
+ depends = qt5-x11extras
depends = openal
depends = glew
source = play-emu::git+https://github.com/jpd002/Play-.git
@@ -17,9 +18,15 @@ pkgbase = play-emu-git
source = git+https://github.com/jpd002/Play--Framework.git
source = git+https://github.com/jpd002/Play--CodeGen.git
source = git+https://github.com/jpd002/Nuanceur.git
- source = git+https://github.com/jpd002/boost-cmake.git
+ source = git+https://github.com/jpd002/libchdr.git
+ source = git+https://github.com/jpd002/AltKit.git
source = git+https://github.com/rs/SDWebImage.git
source = git+https://github.com/gulrak/filesystem.git
+ source = git+https://github.com/facebook/zstd.git
+ source = git+https://github.com/Cyan4973/xxHash.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d34cbee3778f..b86d62390f7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
pkgname=play-emu-git
-pkgver=0.42.r60.gf7acc8d7
-pkgrel=1
+pkgver=0.59.r52.g8e1cc18b
+pkgrel=2
pkgdesc="Play! is an experimental Playstation 2 emulator."
arch=(x86_64)
url="https://purei.org/"
license=(MIT)
-depends=(qt5-base openal glew)
-makedepends=(git cmake ninja qt5-x11extras)
+depends=(qt5-base qt5-x11extras openal glew)
+makedepends=(git cmake ninja nlohmann-json)
source=("${pkgname%-git}::git+https://github.com/jpd002/Play-.git"
"git+https://github.com/jpd002/Play-Dependencies.git"
"git+https://github.com/jpd002/Play--Framework.git"
"git+https://github.com/jpd002/Play--CodeGen.git"
"git+https://github.com/jpd002/Nuanceur.git"
- "git+https://github.com/jpd002/boost-cmake.git"
+ "git+https://github.com/jpd002/libchdr.git"
+ "git+https://github.com/jpd002/AltKit.git"
"git+https://github.com/rs/SDWebImage.git"
- "git+https://github.com/gulrak/filesystem.git")
+ "git+https://github.com/gulrak/filesystem.git"
+ "git+https://github.com/facebook/zstd.git"
+ "git+https://github.com/Cyan4973/xxHash.git")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -25,6 +28,9 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -40,17 +46,20 @@ prepare () {
git config 'submodule.deps/Framework.url' "${srcdir}/Play--Framework"
git config 'submodule.deps/CodeGen.url' "${srcdir}/Play--CodeGen"
git config 'submodule.deps/Nuanceur.url' "${srcdir}/Nuanceur"
- git submodule update
+ git config 'submodule.deps/libchdr.url' "${srcdir}/libchdr"
+ git config 'submodule.deps/AltKit.url' "${srcdir}/AltKit"
+ git -c protocol.file.allow=always submodule update
install -d build
cd "${srcdir}/${pkgname%-git}"/deps/Dependencies
git submodule init
- git config 'submodule.boost-cmake.url' "${srcdir}/boost-cmake"
git config 'submodule.SDWebImage.url' "${srcdir}/SDWebImage"
git config 'submodule.ghc_filesystem.url' "${srcdir}/filesystem"
- git submodule update
+ git config 'submodule.zstd.url' "${srcdir}/zstd"
+ git config 'submodule.xxHash.url' "${srcdir}/xxHash"
+ git -c protocol.file.allow=always submodule update
}
build() {
@@ -63,6 +72,6 @@ package() {
cd "${pkgname%-git}"
install -Dm755 build/Source/ui_qt/Play "${pkgdir}"/usr/bin/play-emu
install -D icons/icon.svg "${pkgdir}"/usr/share/pixmaps/play.svg
- install -D installer_unix/Play.desktop "${pkgdir}"/usr/share/applications/play-emu.desktop
+ install -D installer_unix/org.purei.Play.desktop -t "${pkgdir}"/usr/share/applications/
install -D License.txt "${pkgdir}/usr/share/licenses/${pkgname}"/License.txt
}