summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2017-04-30 19:11:14 +0200
committerKrzysztof AS (3ED)2017-04-30 19:11:14 +0200
commit44ba62bcc087dd785e0d6e237ba27dd085d7d570 (patch)
tree0c3e91aac7b1d43b42a6c9b75a6725b411a94095
parentf080e95908cd6df77ab0b9f10f52bc53381ab266 (diff)
downloadaur-44ba62bcc087dd785e0d6e237ba27dd085d7d570.tar.gz
update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 33 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71f7cf10e7d1..e9a427aa3846 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Apr 30 17:10:16 UTC 2017
pkgbase = pluma-plugins
- pkgver = 1.8.0
- pkgrel = 2
+ pkgver = 1.16.0
+ pkgrel = 1
epoch = 1
url = http://mate-desktop.org/
arch = i686
arch = x86_64
license = GPL
- depends = pluma
+ depends = pluma-1.16>=1.16.0
depends = mate-common
- source = pluma-plugins-1.8.0.tar.gz::http://cygwin.cathedral-networks.org/x86/release/pluma-plugins/pluma-plugins-1.8.0-1-src.tar.xz
- sha256sums = 1c14155ef4474ebb2850d67eb042776c49e4689d515876a015e59146e7fd2eb3
+ conflicts = pluma-plugins-gtk2
+ source = pluma-plugins-1.16.0-1.tar.gz::http://cygwin.cathedral-networks.org/x86/release/pluma-plugins/pluma-plugins-1.16.0-1-src.tar.xz
+ sha256sums = e4ae4684c074cae81b9f05cc2ea034195e3a1dadff64f2efcb7c362d780a8a1d
pkgname = pluma-plugins
diff --git a/PKGBUILD b/PKGBUILD
index 725aeb31aa91..b4723bc39124 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,49 @@
# Mantainer: 3ED <krzysztof1987 at gmail>
# Contributor: adlerweb <get on aur>
-pkgname=pluma-plugins
-pkgver=1.8.0
+# 2017-04-30 facts:
+# - plugins works only with 1.16 version
+# - python plugins works only with gtk2 version
+# more info:
+# https://github.com/yselkowitz/pluma-plugins/issues/6
+
+_pkgname=pluma-plugins
+pkgname=${_pkgname}
+pkgver=1.16.0
_cygrel=1
epoch=1
-pkgrel=2
+pkgrel=1
arch=('i686' 'x86_64')
url="http://mate-desktop.org/"
license=('GPL')
-depends=('pluma' 'mate-common')
-source=(${pkgname}-${pkgver}.tar.gz::http://cygwin.cathedral-networks.org/x86/release/${pkgname}/${pkgname}-${pkgver}-${_cygrel}-src.tar.xz)
-sha256sums=('1c14155ef4474ebb2850d67eb042776c49e4689d515876a015e59146e7fd2eb3')
+depends=('pluma-1.16>=1.16.0' 'mate-common')
+conflicts=("${_pkgname}-gtk2")
+source=(${_pkgname}-${pkgver}-${_cygrel}.tar.gz::http://cygwin.cathedral-networks.org/x86/release/${_pkgname}/${_pkgname}-${pkgver}-${_cygrel}-src.tar.xz)
+sha256sums=('e4ae4684c074cae81b9f05cc2ea034195e3a1dadff64f2efcb7c362d780a8a1d')
+
+# gtk2 uncomment:
+#pkgname=${_pkgname}-gtk2
+#depends=('pluma-gtk2>=1.16.0' 'mate-common')
+#conflicts=("${_pkgname}")
prepare() {
cd "$srcdir"
- bsdtar -xvf "$srcdir/${pkgname}-${pkgver}-${_cygrel}.src/${pkgname}-${pkgver}.tar.gz"
+ bsdtar -xf "$srcdir/${_pkgname}-${pkgver}-${_cygrel}.src/${_pkgname}-${pkgver}.tar.gz"
}
+
build() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${_pkgname}-${pkgver}"
PYTHON=/usr/bin/python2 ./autogen.sh \
--prefix=/usr \
--sbindir=/usr/bin \
- --libexecdir=/usr/lib/${pkgname} \
+ --libexecdir=/usr/lib/${_pkgname} \
--with-plugins=all \
- --with-gtk=2.0 \
- --enable-gtk-doc \
- --enable-python
+ --enable-python
- # For SMP look at MAKEFLAGS="-j8" (where 8 is 8 cpus/cores) in /etc/makepkg.conf
make
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${_pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
}