summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Lau2018-08-24 05:10:43 +0200
committerSebastian Lau2018-08-24 05:10:43 +0200
commit0f647305e486a70ec700764c00c5a235e050a45d (patch)
tree6c62d8e7713f1229e6615d94e60a33bc1da0f0da
parent62d216659880036787cd2cf4451425e0fcc4f126 (diff)
downloadaur-0f647305e486a70ec700764c00c5a235e050a45d.tar.gz
ADD patch sysmacros from upstream
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--sysmacros.patch27
3 files changed, 37 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a0ce799f97b..8e096719a121 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = plymouth
pkgdesc = A graphical boot splash screen with kernel mode-setting support
pkgver = 0.9.3
- pkgrel = 4
+ pkgrel = 5
url = http://www.freedesktop.org/wiki/Software/Plymouth/
- arch = i686
arch = x86_64
license = GPL
makedepends = docbook-xsl
@@ -36,6 +35,7 @@ pkgbase = plymouth
source = plymouth-quit.service.in.patch
source = plymouth-set-default-theme.in.patch
source = plymouth-update-initrd.patch
+ source = sysmacros.patch
md5sums = b261c720888a5431cdfce8494805eab3
md5sums = 65fa2763d5c9bb9f80973ea5e6e3db3e
md5sums = d67132b297ccfb1a877a2efd78076963
@@ -54,6 +54,7 @@ pkgbase = plymouth
md5sums = 165a39dbedcc6e123c8ca05d5b4b2e25
md5sums = f79edbbb30c71b0dbcd102c7dd31660b
md5sums = 0357775c16b5f90f1af485e6a4c80a9e
+ md5sums = d2805e2ac2b4dcaf44f63e9a5f898e94
pkgname = plymouth
diff --git a/PKGBUILD b/PKGBUILD
index 6feda02afcc2..1f547792f901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
pkgname=plymouth
pkgver=0.9.3
-pkgrel=4
+pkgrel=5
pkgdesc="A graphical boot splash screen with kernel mode-setting support"
url="http://www.freedesktop.org/wiki/Software/Plymouth/"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
depends=('libdrm' 'pango' 'systemd')
@@ -38,7 +38,8 @@ source=("http://www.freedesktop.org/software/${pkgname}/releases/${pkgname}-${pk
'sd-plymouth.initcpio_install'
'plymouth-quit.service.in.patch'
'plymouth-set-default-theme.in.patch'
- 'plymouth-update-initrd.patch')
+ 'plymouth-update-initrd.patch'
+ 'sysmacros.patch')
md5sums=('b261c720888a5431cdfce8494805eab3'
'65fa2763d5c9bb9f80973ea5e6e3db3e'
@@ -57,13 +58,15 @@ md5sums=('b261c720888a5431cdfce8494805eab3'
'af3c3eadc80e240416d11b2d5983dfb5'
'165a39dbedcc6e123c8ca05d5b4b2e25'
'f79edbbb30c71b0dbcd102c7dd31660b'
- '0357775c16b5f90f1af485e6a4c80a9e')
+ '0357775c16b5f90f1af485e6a4c80a9e'
+ 'd2805e2ac2b4dcaf44f63e9a5f898e94')
prepare() {
cd "$srcdir"/${pkgname}-${pkgver}
patch -p1 -i $srcdir/plymouth-set-default-theme.in.patch
patch -p1 -i $srcdir/plymouth-update-initrd.patch
patch -p1 -i $srcdir/plymouth-quit.service.in.patch
+ patch -p1 -i $srcdir/sysmacros.patch
}
build() {
diff --git a/sysmacros.patch b/sysmacros.patch
new file mode 100644
index 000000000000..0624037c395d
--- /dev/null
+++ b/sysmacros.patch
@@ -0,0 +1,27 @@
+From e12b5ee34c619e88509f59424068417790b69e04 Mon Sep 17 00:00:00 2001
+From: Sakaki <sakaki@deciban.com>
+Date: Fri, 18 Aug 2017 10:08:23 -0400
+Subject: terminal: add include for sysmacros.h
+
+That file is, in some cases, not included implicitly by sys/types.h.
+
+This commit explicitly includes it.
+---
+ src/libply-splash-core/ply-terminal.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/libply-splash-core/ply-terminal.c b/src/libply-splash-core/ply-terminal.c
+index a0954f2..f3b32fe 100644
+--- a/src/libply-splash-core/ply-terminal.c
++++ b/src/libply-splash-core/ply-terminal.c
+@@ -32,6 +32,7 @@
+ #include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <termios.h>
+ #include <unistd.h>
+ #include <wchar.h>
+--
+cgit v1.1
+