summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2021-10-27 10:34:28 +0200
committerTaijian2021-10-27 10:34:28 +0200
commit5324953cb57668b60f178f33c100c74abb83ca99 (patch)
treeb690c688af6364c66c7da4d022671790c2374816
parente2e8d07351e4ad63239852d3462f845e0340e063 (diff)
downloadaur-5324953cb57668b60f178f33c100c74abb83ca99.tar.gz
remove gdm-plymouth.service
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rw-r--r--plymouth.encrypt_hook8
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19b77a05b084..006fc665806f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,7 +34,7 @@ pkgbase = plymouth
source = plymouthd.conf.patch
sha256sums = 55a461003ece0a4daeffb8b7ac2178977c5ce024a7e688d24f6d2230465b50ba
sha256sums = de4369ad5a5511b684305e3a882c2c56204696514ea8ccdb556dd656eca062e7
- sha256sums = 7afa97d21444cbac7a6213edda09d9fa73ecbef1a6cea1e745f56669760c6120
+ sha256sums = 748e0cfa0e10ab781bc202fceeed46e765ed788784f1b85945187b0f29eafad7
sha256sums = 373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a
sha256sums = 06b31999cf60f49e536c7a12bc1c4f75f2671feb848bf5ccb91a963147e2680d
sha256sums = 86d0230d9393c9d83eb7bb430e6b0fb5e3f32e78fcd30f3ecd4e6f3c30b18f71
@@ -48,4 +48,3 @@ pkgbase = plymouth
sha256sums = 71d34351b4313da01e1ceeb082d9776599974ce143c87e93f0a465f342a74fd2
pkgname = plymouth
-
diff --git a/PKGBUILD b/PKGBUILD
index 0aa191d54a3c..d11dfa3e8693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,7 +42,7 @@ source=("https://gitlab.freedesktop.org/${pkgname}/${pkgname}/-/archive/${pkgver
sha256sums=('55a461003ece0a4daeffb8b7ac2178977c5ce024a7e688d24f6d2230465b50ba'
'de4369ad5a5511b684305e3a882c2c56204696514ea8ccdb556dd656eca062e7'
- '7afa97d21444cbac7a6213edda09d9fa73ecbef1a6cea1e745f56669760c6120'
+ '748e0cfa0e10ab781bc202fceeed46e765ed788784f1b85945187b0f29eafad7'
'373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a'
'06b31999cf60f49e536c7a12bc1c4f75f2671feb848bf5ccb91a963147e2680d'
'86d0230d9393c9d83eb7bb430e6b0fb5e3f32e78fcd30f3ecd4e6f3c30b18f71'
@@ -108,8 +108,9 @@ package() {
for i in {sddm,lxdm,lightdm}-plymouth.service; do
install -Dm644 "$srcdir/$i" "$pkgdir/usr/lib/systemd/system/$i"
done
-
- ln -s "/usr/lib/systemd/system/gdm.service" "$pkgdir/usr/lib/systemd/system/gdm-plymouth.service"
+
+# soft-linking gdm-plymouth is deprecated and no longer necessary
+# ln -s "/usr/lib/systemd/system/gdm.service" "$pkgdir/usr/lib/systemd/system/gdm-plymouth.service"
install -Dm644 "$srcdir/plymouth-deactivate.service" "$pkgdir/usr/lib/systemd/system/plymouth-deactivate.service"
# install -Dm644 "$srcdir/plymouth-start.path" "$pkgdir/usr/lib/systemd/system/plymouth-start.path"
diff --git a/plymouth.encrypt_hook b/plymouth.encrypt_hook
index a623debf54a6..8acb9af138e3 100644
--- a/plymouth.encrypt_hook
+++ b/plymouth.encrypt_hook
@@ -51,9 +51,15 @@ EOF
for cryptopt in ${cryptoptions//,/ }; do
case ${cryptopt} in
- allow-discards)
+ allow-discards|discard)
cryptargs="${cryptargs} --allow-discards"
;;
+ no-read-workqueue|perf-no_read_workqueue)
+ cryptargs="${cryptargs} --perf-no_read_workqueue"
+ ;;
+ no-write-workqueue|perf-no_write_workqueue)
+ cryptargs="${cryptargs} --perf-no_write_workqueue"
+ ;;
*)
echo "Encryption option '${cryptopt}' not known, ignoring." >&2
;;