summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Chamberlain2019-08-21 19:42:08 +1000
committerChris Chamberlain2019-08-21 19:49:31 +1000
commit6277f1fface572d13124c7b084fac0d1358f59ce (patch)
treecedf3b1a46a8d124f1dafe247c5df20ec1495a66
downloadaur-plymouth-theme-minimal-dark-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f331050e6c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plymouth-theme-minimal-dark-git
+ pkgdesc = Minimal and dark Arch Linux theme for Plymouth, based upon the Debian theme
+ pkgver = r8.62e95c8
+ pkgrel = 1
+ url = https://github.com/bobwallis/minimal-dark
+ arch = any
+ license = unknown
+ makedepends = git
+ source = git+https://github.com/bobwallis/minimal-dark
+ sha256sums = SKIP
+
+pkgname = plymouth-theme-minimal-dark-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a3c44b53ec89
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+minimal-dark/
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04687715cfbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chris Chamberlain <chris@chamberlain.id.au>
+_themename=minimal-dark
+pkgname=plymouth-theme-minimal-dark-git
+pkgver=r8.62e95c8
+pkgrel=1
+arch=('any')
+pkgdesc="Minimal and dark Arch Linux theme for Plymouth, based upon the Debian theme"
+url="https://github.com/bobwallis/minimal-dark"
+license=('unknown')
+groups=()
+depends=()
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/bobwallis/minimal-dark')
+noextract=()
+sha256sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "minimal-dark"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "minimal-dark"/plymouth
+
+ _themedir="$pkgdir/usr/share/plymouth/themes/$_themename"
+
+ install -Dm 0644 logo.png "${_themedir}/logo.png"
+ install -Dm 0644 minimal-dark.plymouth "${_themedir}/minimal-dark.plymouth"
+ install -Dm 0644 minimal-dark.script "${_themedir}/minimal-dark.script"
+ install -Dm 0644 password_field.png "${_themedir}/password_field.png"
+ install -Dm 0644 progress_dot_off.png "${_themedir}/progress_dot_off.png"
+ install -Dm 0644 progress_dot_on.png "${_themedir}/progress_dot_on.png"
+}