summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianqiu Zhang2020-06-15 15:25:53 -0700
committerJianqiu Zhang2020-06-15 15:25:53 -0700
commit258d5907d33f775cf271989606125aba34c77584 (patch)
tree7ae499db95b33585dc778893773a2433852fd88c
parentbca477ac4b7d3e280d05c7c11aa45f8add23976a (diff)
downloadaur-258d5907d33f775cf271989606125aba34c77584.tar.gz
Try to fix bugs from namcap
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00ccb49e12cd..8cd209996f4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = pmdk-git
pkgdesc = Persistent Memory Development Kit.
- pkgver = 1.6.r49.g6e9868c93
+ pkgver = 1.6.1.r149.g99ae6eb7f
pkgrel = 1
url = http://pmem.io
arch = x86_64
- license = Intel
+ license = BSD
makedepends = git
- depends = autoconf
- depends = pkgconf
+ makedepends = pandoc
+ makedepends = autoconf
+ makedepends = pkgconf
+ makedepends = man-db
+ depends = python
depends = ndctl
source = git://github.com/pmem/pmdk.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0d3c029d1a3d..e2f170435d5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,24 @@
pkgname=pmdk-git
_gitname="pmdk"
-pkgver=1.6.r49.g6e9868c93
+pkgver=1.8.r910.g6c7e703d2
pkgrel=1
-epoch=
pkgdesc="Persistent Memory Development Kit."
arch=("x86_64")
url="http://pmem.io"
-license=("Intel")
-groups=()
-depends=("autoconf" "pkgconf" "ndctl")
-makedepends=("git")
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
+license=(BSD)
+depends=("python" "ndctl")
+makedepends=("git" "pandoc" "autoconf" "pkgconf" "man-db")
source=("git://github.com/pmem/pmdk.git")
noextract=()
md5sums=('SKIP')
-validpgpkeys=()
prepare() {
- cd "$_gitname"
- git checkout stable-1.6
+ echo "prepare()"
}
pkgver() {
- cd "$_gitname"
+ cd "$srcdir/$_gitname"
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
@@ -43,5 +30,6 @@ build() {
package() {
cd "$srcdir/$_gitname"
- make install DESTDIR="$pkgdir"
+ make install DESTDIR="$pkgdir"
+ echo $pkgdir
}