summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorY2017-11-11 13:07:27 +0100
committerY2017-11-11 13:17:20 +0100
commitb3689c4ebc5d4d76e1e6f42413a6cf20c623c860 (patch)
treec15e96c48c5ee5cf4eaf2c1651a6c1199c362780
downloadaur-poco178.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e35691771e7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = poco178
+ pkgdesc = C++ class libraries for network-centric, portable applications, complete edition with debug libraries
+ pkgver = 1.7.8_p3
+ pkgrel = 1
+ url = http://www.pocoproject.org/
+ arch = i686
+ arch = x86_64
+ license = custom:boost
+ makedepends = cmake
+ depends = libmariadbclient
+ depends = openssl
+ depends = unixodbc
+ source = http://pocoproject.org/releases/poco-1.7.8/poco-1.7.8p3-all.tar.bz2
+ sha256sums = 23f2ae2dd373cade48b393b6e440ebc75ecff50f4d37c0cfa80b7723904386b6
+
+pkgname = poco178
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a442fd49f4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Y. <theYinYeti@yalis.fr>, based on the work of:
+# Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Maintainer: Ido Rosen <ido@kernel.org>
+# Contributor: Ross Whitfield <whitfieldre@ornl.gov>
+# Contributor: Mateusz Paluszkiewcz <aifam96 at gmail dot com>
+# Contributor: Christopher Reimer <vdr4arch at creimer dot net>
+
+pkgname=poco178
+pkgver=1.7.8_p3
+_pkgver=${pkgver/_/}
+pkgrel=1
+pkgdesc="C++ class libraries for network-centric, portable applications, complete edition with debug libraries"
+arch=('i686' 'x86_64')
+url="http://www.pocoproject.org/"
+license=('custom:boost')
+depends=('libmariadbclient' 'openssl' 'unixodbc')
+makedepends=('cmake')
+source=("http://pocoproject.org/releases/poco-${_pkgver%p?}/poco-${_pkgver}-all.tar.bz2")
+sha256sums=('23f2ae2dd373cade48b393b6e440ebc75ecff50f4d37c0cfa80b7723904386b6')
+
+build() {
+ cd "${srcdir}/poco-${_pkgver}-all"
+ mkdir -p build
+ cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/poco-${_pkgver}-all"/build
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 '../LICENSE' "${pkgdir}/usr/share/licenses/poco/LICENSE"
+
+ # Old version! Do not conflict with the current version
+ cd "${pkgdir}"
+ for old in usr/bin/* usr/include/Poco usr/lib/cmake/Poco usr/share/licenses/poco; do
+ mv $old{,-$_pkgver}
+ done
+ rm -f usr/lib/*.so
+}