summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-06-25 13:51:01 +0200
committerwillemw122021-06-25 13:51:01 +0200
commit85f1dee22ce1533ecc44d657c0ac3c247d9bd35e (patch)
tree1d4a178a34b6d00f8e816c9ce09d6c79160dd22e
parenta25c3bd528527d5a01088296e350a9f0e7ec3574 (diff)
downloadaur-podget-git.tar.gz
Remove chmod SCRIPTS folder
Change source URL from git:// to git+https://. Change "install -D". Remove cd.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e32514d6ff6..b937323cc3f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 19 13:24:31 UTC 2016
pkgbase = podget-git
pkgdesc = Simple tool to automate downloading of podcasts
- pkgver = 0.7.11.r0.gfedd0af
+ pkgver = 0.8.8.r20.g750fa49
pkgrel = 1
url = https://github.com/dvehrs/podget
arch = any
@@ -11,8 +9,7 @@ pkgbase = podget-git
depends = wget
provides = podget
conflicts = podget
- source = podget-git::git://github.com/dvehrs/podget.git
- md5sums = SKIP
+ source = podget-git::git+https://github.com/dvehrs/podget.git
+ sha256sums = SKIP
pkgname = podget-git
-
diff --git a/PKGBUILD b/PKGBUILD
index fbc2dc240aa8..f44802e881a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=podget
-pkgname=$_pkgname-git
-pkgver=0.7.11.r0.gfedd0af
+pkgname=podget-git
+pkgver=0.8.8.r20.g750fa49
pkgrel=1
pkgdesc="Simple tool to automate downloading of podcasts"
arch=('any')
@@ -10,25 +9,19 @@ url="https://github.com/dvehrs/podget"
license=('GPL3')
makedepends=('git')
depends=('wget')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($pkgname::git://github.com/dvehrs/podget.git)
-md5sums=('SKIP')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::git+$url.git)
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd $pkgname
+ install -Dm644 $pkgname/README -t "$pkgdir/usr/share/${pkgname%-git}"
+ cp -a $pkgname/SCRIPTS/ "$pkgdir/usr/share/${pkgname%-git}/scripts/"
- make prefix=/usr DESTDIR="$pkgdir" changelog.gz install
-
- install -Dm644 README "$pkgdir/usr/share/$pkgname/README"
-
- cp -r SCRIPTS/ "$pkgdir/usr/share/$pkgname/scripts/"
- find "$pkgdir/usr/share/$pkgname/scripts/" -type d -exec chmod 755 '{}' \;
- find "$pkgdir/usr/share/$pkgname/scripts/" -type f -exec chmod 644 '{}' \;
+ make -C $pkgname prefix=/usr DESTDIR="$pkgdir/" changelog.gz install
}