summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornightuser2024-04-04 18:16:15 +0100
committernightuser2024-04-04 18:16:15 +0100
commit9fb9b58b4d13c5ec474a9c07424564e291f2b2e2 (patch)
tree82229e6bde991e4d93ba79fdccac18949b1e7dab
parentd2621afc4549411a0ef2a775239c64eb7804988d (diff)
downloadaur-podman-compose-git.tar.gz
Fix pkgver; Fix branch; Bump version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c909ae6432a2..29a4556a06f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = podman-compose-git
pkgdesc = A script to run docker-compose.yml using podman
- pkgver = 1.0.3.r17.0bd493f
+ pkgver = 1.0.7.r161.6103df7
pkgrel = 1
epoch = 1
url = https://github.com/containers/podman-compose
@@ -14,7 +14,7 @@ pkgbase = podman-compose-git
optdepends = podman-dnsname: the containers will be able to resolve each other if they are on the same CNI network
provides = podman-compose
conflicts = podman-compose
- source = podman-compose::git+https://github.com/containers/podman-compose#branch=devel
+ source = podman-compose::git+https://github.com/containers/podman-compose
sha256sums = SKIP
pkgname = podman-compose-git
diff --git a/PKGBUILD b/PKGBUILD
index e04c5333965e..76b9fe213431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nightuser <nightuser.android@gmail.com>
pkgname=podman-compose-git
-pkgver=1.0.3.r17.0bd493f
+pkgver=1.0.7.r161.6103df7
pkgrel=1
epoch=1
pkgdesc="A script to run docker-compose.yml using podman"
@@ -13,26 +13,26 @@ makedepends=('git' 'python-setuptools')
optdepends=('podman-dnsname: the containers will be able to resolve each other if they are on the same CNI network')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/containers/podman-compose#branch=devel")
+source=("${pkgname%-git}::git+https://github.com/containers/podman-compose")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${srcdir}/${pkgname%-git}"
printf "%s.%s" \
- "$(grep -Po "(?<=__version__ = ').*(?=')" podman_compose.py)" \
+ "$(grep -Po "(?<=__version__ = ).*" podman_compose.py | xargs)" \
"$(git describe --long | sed -e "s/^$(git describe --abbrev=0)-//" -e 's/\([^-]*-\)g/r\1/;s/-/./g')"
# Alt. way of getting version number:
# "$(python -c 'from podman_compose import __version__; print(__version__)')"
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${srcdir}/${pkgname%-git}"
python setup.py build
}
package() {
- cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "${srcdir}/${pkgname%-git}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
# vim: set et ts=2 sw=2: