summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTids2016-03-27 22:14:05 +0200
committerTids2016-03-27 22:14:05 +0200
commit2067d7bfc116c7509f77cb4cb4042adad3cf08b6 (patch)
treec558a05a9919ef146c8683f545f7ac5505132411
downloadaur-2067d7bfc116c7509f77cb4cb4042adad3cf08b6.tar.gz
switch from pokemon-revolution-online to *-bin ; we only use the binary version since there is no source code
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD74
-rw-r--r--change.log34
-rw-r--r--copyright7
-rwxr-xr-xnet.pokemon-revolution-online.desktop32
-rw-r--r--pokemonrevolution18
-rw-r--r--pokemonrevolution.svg156
7 files changed, 347 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a962f647412
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pokemon-revolution-online-bin
+ pkgdesc = A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games.
+ pkgver = 0.94.20160327
+ pkgrel = 1
+ url = http://pokemon-revolution-online.net
+ changelog = change.log
+ arch = x86_64
+ license = custom
+ depends = gcc-libs-multilib
+ optdepends = gtk2: required for the Unity ScreenSelector plugin
+ conflicts = pokemon-revolution-online
+ source = http://tiny.cc/PROLinux
+ source = net.pokemon-revolution-online.desktop
+ source = change.log
+ source = pokemonrevolution
+ source = copyright
+ source = pokemonrevolution.svg
+ md5sums = 4ca6f28da8d25670ac4b13146dd38a3c
+ md5sums = 3215173b6f1673d868e71f1d953ed9d2
+ md5sums = d791b50b1432a9dd8ca5e342e03a991c
+ md5sums = 1b667f450341675b6b2c1750e034516c
+ md5sums = 0efcd0393015ff149217f9ced4670513
+ md5sums = 8446ead3097e1b87e3a63b667d956569
+
+pkgname = pokemon-revolution-online-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6c178e39e0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Fabian <plusfabi[AT+thegoogleadress]>
+pkgname=pokemon-revolution-online-bin
+pkgver=0.94.20160327
+pkgrel=1
+pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
+arch=('x86_64')
+url="http://pokemon-revolution-online.net"
+license=('custom')
+depends=('gcc-libs-multilib')
+optdepends=('gtk2: required for the Unity ScreenSelector plugin')
+conflicts=('pokemon-revolution-online')
+changelog="change.log"
+source=('http://tiny.cc/PROLinux' 'net.pokemon-revolution-online.desktop' 'change.log' 'pokemonrevolution' 'copyright' 'pokemonrevolution.svg')
+md5sums=('4ca6f28da8d25670ac4b13146dd38a3c'
+ '3215173b6f1673d868e71f1d953ed9d2'
+ 'd791b50b1432a9dd8ca5e342e03a991c'
+ '1b667f450341675b6b2c1750e034516c'
+ '0efcd0393015ff149217f9ced4670513'
+ '8446ead3097e1b87e3a63b667d956569')
+
+package() {
+ cd "${srcdir}"
+
+ # Variables
+ ## i know this isnt a good thing and nobody wants to see this on aur, but itll make things easier for me #Fabian
+ ## directory files naming is usually VNAMING_Date, binary VNAMING.x86_64
+ __VNAMING="PROLinux64_94"
+
+ # CREATE FOLDERS
+ ## copy the folderstructure of the original without content.
+ /usr/bin/find "." -type d -exec \
+ install -d -m755 "${pkgdir}/opt/Pokemon Revolution/{}" \;
+
+ # MOVE CONTENT
+ ## minimize memory usage by using mv instead of install
+ ## this also fits more in our "permissions" to use it hashtag copyright, hashtag do NOT modify anything
+ /usr/bin/find "./${__VNAMING}_Data" \
+ -type f -exec /usr/bin/mv "{}" "${pkgdir}/opt/Pokemon Revolution/{}" \; -exec /usr/bin/chmod 644 "${pkgdir}/opt/Pokemon Revolution/{}" \;
+ ## move to new position
+ /usr/bin/mv "${srcdir}/${__VNAMING}.x86_64" "${pkgdir}/opt/Pokemon Revolution/${__VNAMING}.x86_64"
+ ## set permission
+ /usr/bin/chmod 755 "${pkgdir}/opt/Pokemon Revolution/${__VNAMING}.x86_64"
+
+ #MOVE ICON
+ ## cause we can not use the iroginal icon, we use a *.svg version.
+ install -D -m644 "${srcdir}/pokemonrevolution.svg" \
+ "${pkgdir}/usr/share/pixmaps/pokemonrevolution.svg"
+
+ # DESKTOP FILE
+ ## Set the path to our pokemon scriptfile
+ /usr/bin/sed -i "s/GAMEEXECPATHSETBYPKGBUILD/\/usr\/bin\/pokemonrevolution/" "${srcdir}/net.pokemon-revolution-online.desktop"
+ ## let's Install the *.desktop file
+ install -D -m644 "${srcdir}/net.pokemon-revolution-online.desktop" \
+ "${pkgdir}/usr/share/applications/net.pokemon-revolution-online.desktop"
+
+ # START SCRIPT
+ ## set the correct directory
+ /usr/bin/sed -i "s/GAMEDIRNAMESETBYPKGBUILD/\/opt\/Pokemon\ Revolution/" "${srcdir}/pokemonrevolution"
+ ## set the correct filename
+ /usr/bin/sed -i "s/GAMEBINARYNAMESETBYPKGBUILD/${__VNAMING}.x86_64/" "${srcdir}/pokemonrevolution"
+
+ ## move it!
+ install -D -m755 "${srcdir}/pokemonrevolution" \
+ "${pkgdir}/usr/bin/pokemonrevolution"
+
+ # COPYRIGHT FILE
+ ## move the copyright text
+ install -D -m644 "${srcdir}/copyright" \
+ "${pkgdir}/usr/share/licenses/pokemon-revolution-online/copyright"
+
+ # RM PROLinux
+ ## lets remove the zip file since it'll save some space and we dont need it anymore
+ rm ../PROLinux
+}
diff --git a/change.log b/change.log
new file mode 100644
index 000000000000..e687c23f8ee5
--- /dev/null
+++ b/change.log
@@ -0,0 +1,34 @@
+Game Changelog
+http://pokemon-revolution-online.net/Forum/viewtopic.php?f=14&t=4563
+
+Packaging
+switch from AUR pokemon-revolution-online to pokemon-revolution-online-bin
+cause we dont have the sources, its binary only
+
+0.94.20160327-1
+* PRO 0.94
+
+0.93_3.20160206-2
+* remove that X-DBUS-StartupType in *.desktop
+
+0.93_3.20160206-2
+* move directory from /opt/pokemonrevolutiononline to /opt/Pokemon Revolution
+* use our own *.svg icon.
+* gtk2 is now optional since we only need it for the screenselector plugin (i dont know this for sure..)
+
+0.93_3.20160206-1
+* PRO 0.93_3 - gogogo!
+
+0.93_2.20160202.1
+* correct directory permissions 775 -> 755
+* move files instead of copy them to save 50% (around 2GiB) memory while makepkg
+* no pro.install anymore (we dont need it)
+* use sed to set the correct path/names to alle files. (yep i'm lazy and this way its easier to maintain)
+* rm unused "prolinux" zip file before packaging because 130MiB!
+
+0.93_2.20160202.0
+* ready for PRO 0.93_2
+* enforce opengl to workaround a bug that makes the game start in direct3d mode on linux -> "PROLinux93_2.x86_64 -force-opengl"
+* new starter "pokemonrevolutiononline" in /usr/bin
+* now use <0.folderversion>.<yyyymmdd> to get a better package versioning.
+###################
diff --git a/copyright b/copyright
new file mode 100644
index 000000000000..9f53ff4935ce
--- /dev/null
+++ b/copyright
@@ -0,0 +1,7 @@
+Permission is granted to temporarily download one copy of the materials (information or software) from PRO's websites for personal, non-commercial transitory viewing only. This is the grant of a license, not a transfer of title, and under this license you may not:
+Modify or copy the materials;
+Use the materials for any commercial purpose, or for any public display (commercial or non-commercial);
+Attempt to decompile or reverse engineer any software contained on PRO's websites;
+Remove any copyright or other proprietary notations from the materials; or
+Transfer the materials to another person or "mirror" the materials on any other server.
+This license shall automatically terminate if you violate any of these restrictions and may be terminated by PRO at any time. Upon terminating your viewing of these materials or upon the termination of this license, you must destroy any downloaded materials in your possession whether in electronic or printed format.
diff --git a/net.pokemon-revolution-online.desktop b/net.pokemon-revolution-online.desktop
new file mode 100755
index 000000000000..562ab2818b6f
--- /dev/null
+++ b/net.pokemon-revolution-online.desktop
@@ -0,0 +1,32 @@
+[Desktop Entry]
+Comment[de_DE]=Das freie, Community getriebenes MMO, aus der Welt der offiziellen Pokémon-Spiele
+Comment=A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games
+Exec=GAMEEXECPATHSETBYPKGBUILD
+GenericName=Pokémon MMORPG
+Icon=pokemonrevolution
+Name=Pokémon Revolution
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Game;
+Actions=Support;Rules;Community;Register;
+
+[Desktop Action Support]
+Name=Support
+Name[de]=Unterstützung
+Exec=xdg-open http://pokemon-revolution-online.net/Register.php
+
+[Desktop Action Rules]
+Name=Rules
+Name[de]=Regeln
+Exec=xdg-open http://pokemon-revolution-online.net/rules.php
+
+[Desktop Action Community]
+Name=Community
+Name[de]=Community
+Exec=xdg-open http://pokemon-revolution-online.net/Forum/index.php
+
+[Desktop Action Register]
+Name=Register
+Name[de]=Registrieren
+Exec=xdg-open http://pokemon-revolution-online.net/Support.php \ No newline at end of file
diff --git a/pokemonrevolution b/pokemonrevolution
new file mode 100644
index 000000000000..4105fd137028
--- /dev/null
+++ b/pokemonrevolution
@@ -0,0 +1,18 @@
+#! /bin/bash
+## helper script to run PRO.
+GAMEDIR="GAMEDIRNAMESETBYPKGBUILD"
+GAMEBINARY="GAMEBINARYNAMESETBYPKGBUILD"
+
+## enforce opengl to workaround a bug that makes the game start in direct3d mode on linux -> "-force-opengl"
+OPTIONS="-force-opengl"
+
+echo -e "--> \"${GAMEDIR}/${GAMEBINARY}\" ${OPTIONS} ${@}"
+echo -e "..."
+
+## to workaround an error that the game can't find some importtant files on some systems, we cd to the game root first
+cd "${GAMEDIR}"
+
+## start the game!
+"${GAMEDIR}/${GAMEBINARY}" ${OPTIONS} ${@}
+
+exit \ No newline at end of file
diff --git a/pokemonrevolution.svg b/pokemonrevolution.svg
new file mode 100644
index 000000000000..8c53c3977895
--- /dev/null
+++ b/pokemonrevolution.svg
@@ -0,0 +1,156 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="64"
+ height="64"
+ viewBox="0 0 64.000001 64.000001"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.91 r13725"
+ sodipodi:docname="pokemonrevolution.svg">
+ <defs
+ id="defs4">
+ <linearGradient
+ inkscape:collect="always"
+ id="linearGradient4213">
+ <stop
+ style="stop-color:#eff0f1;stop-opacity:1;"
+ offset="0"
+ id="stop4215" />
+ <stop
+ style="stop-color:#acb1b8;stop-opacity:1"
+ offset="1"
+ id="stop4217" />
+ </linearGradient>
+ <linearGradient
+ inkscape:collect="always"
+ id="linearGradient4209">
+ <stop
+ style="stop-color:#eb98a0;stop-opacity:1"
+ offset="0"
+ id="stop4197" />
+ <stop
+ style="stop-color:#da4453;stop-opacity:1"
+ offset="1"
+ id="stop4199" />
+ </linearGradient>
+ <radialGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4209"
+ id="radialGradient4201"
+ cx="21.806177"
+ cy="5.2933025"
+ fx="21.806177"
+ fy="5.2933025"
+ r="28.816406"
+ gradientTransform="matrix(0.10410737,1.0410736,-1.7388981,0.17388984,29.93433,-17.622285)"
+ gradientUnits="userSpaceOnUse" />
+ <radialGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient4213"
+ id="radialGradient4219"
+ cx="22.850681"
+ cy="34.214848"
+ fx="22.850681"
+ fy="34.214848"
+ r="29"
+ gradientTransform="matrix(-1.1155519e-7,1.5172414,-2.1726875,-5.1639388e-8,93.338176,0.33000306)"
+ gradientUnits="userSpaceOnUse" />
+ </defs>
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="2"
+ inkscape:cx="-3.741474"
+ inkscape:cy="6.3202887"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ units="px"
+ inkscape:object-paths="true"
+ inkscape:snap-intersection-paths="true"
+ inkscape:object-nodes="true"
+ inkscape:snap-smooth-nodes="true"
+ inkscape:snap-midpoints="true"
+ inkscape:window-width="1920"
+ inkscape:window-height="1000"
+ inkscape:window-x="0"
+ inkscape:window-y="43"
+ inkscape:window-maximized="1">
+ <inkscape:grid
+ type="xygrid"
+ id="grid4147" />
+ </sodipodi:namedview>
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Ebene 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(0,-988.36216)">
+ <path
+ style="opacity:1;fill:url(#radialGradient4219);fill-opacity:1;stroke:none;stroke-width:3;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ d="M 3.0839846,30.318359 C 3.0397194,30.877975 3.0117128,31.438758 3,32 3,48.016258 15.983742,61 32,61 48.016258,61 61,48.016258 61,32 60.997422,31.40575 60.976579,30.811719 60.9375,30.21875 60.29113,36.598474 51.370913,42.01517 38.972656,43.556641 38.682556,47.193232 35.648143,49.997302 32,50 28.351799,49.998401 25.316514,47.195161 25.025391,43.558594 12.702358,42.023437 3.8106143,36.657838 3.0839846,30.318359 Z"
+ transform="translate(0,988.36216)"
+ id="path4149"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="ccscccccc" />
+ <circle
+ style="opacity:1;fill:#ffffff;fill-opacity:1;stroke:none;stroke-width:3;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ id="path4168"
+ cx="32"
+ cy="1031.3622"
+ r="5" />
+ <path
+ style="opacity:1;fill:#262626;fill-opacity:1;stroke:none;stroke-width:3;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ d="M 60.798828,28.890625 C 59.607391,35.019309 50.804297,40.103348 38.84375,41.570312 38.167368,38.328422 35.311696,36.004114 32,36 28.684775,36.000611 25.824618,38.326731 25.148438,41.572266 13.220784,40.118762 4.4159695,35.067435 3.1660156,28.960938 3.1280652,29.412708 3.100714,29.865306 3.0839844,30.318359 3.8106143,36.657838 12.702358,42.023437 25.025391,43.558594 25.316514,47.195161 28.351799,49.998401 32,50 c 3.648143,-0.0027 6.682556,-2.806768 6.972656,-6.443359 C 51.372238,42.014958 60.292802,36.597258 60.9375,30.216797 60.901446,29.773735 60.85521,29.331561 60.798828,28.890625 Z M 32,38 c 2.761415,0 4.999988,2.238573 5,5 -1.2e-5,2.761427 -2.238585,5 -5,5 -2.761415,0 -4.999988,-2.238573 -5,-5 1.2e-5,-2.761427 2.238585,-5 5,-5 z"
+ transform="translate(0,988.36216)"
+ id="path4163"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="cccccccccccsssss" />
+ <path
+ id="path4191"
+ transform="translate(0,988.36216)"
+ d="M 32,3 C 17.162656,3.0032419 4.7208984,14.20529 3.1660156,28.960938 l 0,0.0039 C 4.4190913,35.069852 13.223269,40.119249 25.148438,41.572266 25.824618,38.326731 28.684775,36.000611 32,36 c 3.311696,0.0041 6.167368,2.328422 6.84375,5.570312 C 50.804297,40.103348 59.607391,35.019309 60.798828,28.890625 59.212012,14.176195 46.799734,3.0173509 32,3 Z"
+ style="opacity:1;fill:url(#radialGradient4201);fill-opacity:1;stroke:none;stroke-width:3;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="cccccccc" />
+ <ellipse
+ cy="1031.3622"
+ cx="32"
+ id="circle4211"
+ style="opacity:1;fill:#eff0f1;fill-opacity:1;stroke:none;stroke-width:3;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ rx="4"
+ ry="4.0000224" />
+ <path
+ id="path4193"
+ transform="translate(0,988.36216)"
+ d="M 28.035156,42.494141 C 28.012751,42.661847 28.001008,42.830807 28,43 c 1.2e-5,2.209143 1.79087,4 4,4 2.20913,0 3.999988,-1.790857 4,-4 -0.0015,-0.165282 -0.01324,-0.330312 -0.03516,-0.494141 C 35.710337,44.502109 34.012396,45.998472 32,46 c -2.016332,-0.0023 -3.715747,-1.50496 -3.964844,-3.505859 z"
+ style="opacity:0.4;fill:#262626;fill-opacity:1;stroke:none;stroke-width:3;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="ccscccc" />
+ </g>
+</svg>