summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTids2017-01-23 18:56:27 +0100
committerTids2017-01-23 18:56:27 +0100
commit70c96b3179c504c537392dc3cf16a5e96ce4e5ac (patch)
tree305c4ff15d2637f509725c528396731cbb34ad11
parentd90d1e36f201c95307706ee1f39a797732a91b2d (diff)
downloadaur-70c96b3179c504c537392dc3cf16a5e96ce4e5ac.tar.gz
smaller cleanup + new upstream version
-rw-r--r--.SRCINFO2
-rw-r--r--INSTALL6
-rw-r--r--PKGBUILD28
3 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52cc24ce16c1..0af61fb34674 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pokemon-revolution-online-bin
pkgdesc = A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games.
- pkgver = 0.95.8.20161201MERRYCHRISTMAS
+ pkgver = 0.95.9.20170123
pkgrel = 1
url = http://pokemon-revolution-online.net
install = INSTALL
diff --git a/INSTALL b/INSTALL
index 48eab9a5263d..d62c59e78177 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,6 +1,4 @@
post_install() {
-# xdg-icon-resource forceupdate
-# update-desktop-database -q
echo
echo
echo -e "\t GAME NOTES"
@@ -14,11 +12,9 @@ post_install() {
echo
echo
-}
+}
post_upgrade() {
-# xdg-icon-resource forceupdate
-# update-desktop-database -q
echo
echo "Thanks for using my pkg :)"
echo
diff --git a/PKGBUILD b/PKGBUILD
index 101bc9921a09..2e003a0940cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Fabian <plusfabi[AT+thegoogleadress]>
pkgname=pokemon-revolution-online-bin
-pkgver=0.95.8.20161201MERRYCHRISTMAS
+pkgver=0.95.9.20170123
pkgrel=1
pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
arch=('x86_64')
@@ -22,14 +22,14 @@ package() {
# Variables
## i know this isnt a good thing and nobody wants to see this on aur, but itll make things easier for me #Fabian
- ## directory files naming is usually VNAMING_Date, binary VNAMING.x86_64
+ ## directory files naming is usually VNAMING_Date, binary VNAMING.x86_64
__VNAMING="PROLinux64" ##like PROLinux95_45_data, PROLinux95_45.x86_64
-
+
__DLDIR=$(xdg-user-dir DOWNLOAD) ##downloaddirectory
__DDLA="http://tiny.cc/PROLinux" ##download link
- __DDLFN="PROXmasLinux.zip" ##filename
- __DDLFMD5="6ee28befaee8a13a564bfc8fd28f1a9f" #md5sum
-
+ __DDLFN="PROLinuxPikachu.zip" ##filename
+ __DDLFMD5="b614a0c9722808105e4a1ed5d8be152f" #md5sum
+
## "Something's missing"? -> No One Cares - Atreyu c;
if [ ! -f ${__DLDIR}/${__DDLFN} ]; then
{
@@ -39,8 +39,8 @@ package() {
}
fi
## lets check the md5sum
- if [ "$(md5sum ${__DLDIR}/${__DDLFN} | awk '{print $1}')" != "${__DDLFMD5}" ]; then
- {
+ if [ "$(md5sum ${__DLDIR}/${__DDLFN} | awk '{print $1}')" != "${__DDLFMD5}" ]; then
+ {
echo "${__DLDIR}/${__DDLFN} MD5 MISMATCH, please remove the old file before downloading"
echo "rm \"${__DLDIR}/${__DDLFN}\""
echo "Download: ${__DDLA}"
@@ -48,17 +48,17 @@ package() {
echo "maybe this pkgbuild is out-of-date. please report this:"
echo "https://aur.archlinux.org/packages/pokemon-revolution-online-bin/"
exit 1
- }
+ }
fi
-
+
#bsdtar -x -p -f "${__DLDIR}/${__DDLFN}"
- ## we're using unzip for now, since bsdtar cant handle the zip file
+ ## we're using unzip for now, since bsdtar cant handle the zip file
## bsdtar: Invalid central directory signature
## bsdtar: Error exit delayed from previous errors.
unzip "${__DLDIR}/${__DDLFN}"
-
+
# CREATE FOLDERS
- ## copy the folderstructure of the original without content.
+ ## copy the folderstructure of the original without content.
/usr/bin/find "." -type d -exec \
install -d -m755 "${pkgdir}/opt/Pokemon Revolution/{}" \;
@@ -82,7 +82,7 @@ package() {
/usr/bin/sed -i "s/GAMEEXECPATHSETBYPKGBUILD/\/usr\/bin\/pokemonrevolution/" "${srcdir}/net.pokemon-revolution-online.desktop"
## let's Install the *.desktop file
install -D -m644 "${srcdir}/net.pokemon-revolution-online.desktop" \
- "${pkgdir}/usr/share/applications/net.pokemon-revolution-online.desktop"
+ "${pkgdir}/usr/share/applications/net.pokemon-revolution-online.desktop"
# START SCRIPT
## set the correct directory