summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:43:14 +0300
committervlad2015-07-08 15:43:14 +0300
commitdde4221514bbc963cfb4829f86c01b918a549ca5 (patch)
tree6eb5e39879b7e517b89c633bacbe550724649706
downloadaur-poker-eval.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63a40fcc242e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = poker-eval
+ pkgdesc = C library to evaluate poker hands
+ pkgver = 138.0
+ pkgrel = 1
+ url = http://gna.org/projects/pokersource/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://download.gna.org/pokersource/sources/poker-eval-138.0.tar.gz
+ md5sums = 8398b5b98c8ebd1cc03dfac96b477012
+
+pkgname = poker-eval
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91483f4a34da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributors: Eduard "bekks" Warkentin <eduard.warkentin@gmail.com>
+# Milan Hrabánek <hrabi@linuxwaves.com>
+# Anton Leontiev <bunder@t-25.ru>
+# Andrew Black <agwblack@gmail.com>
+
+pkgname=poker-eval
+pkgver=138.0
+pkgrel=1
+pkgdesc="C library to evaluate poker hands"
+arch=('i686' 'x86_64')
+url="http://gna.org/projects/pokersource/"
+license=('GPL')
+source=(http://download.gna.org/pokersource/sources/${pkgname}-${pkgver}.tar.gz)
+md5sums=('8398b5b98c8ebd1cc03dfac96b477012')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make prefix=$pkgdir/usr/ install || return 1
+}