summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Kądziołka2019-05-21 22:08:04 +0200
committerJakub Kądziołka2019-05-21 22:08:04 +0200
commit260c4afc3a85de695a13ff76f0140bd711112c44 (patch)
tree0b13e7ae80128bce1a74c784344408960703d7e5
downloadaur-polished-map-git.tar.gz
Initial comit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f530828b48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = polished-map-git
+ pkgdesc = A map and tileset editor for pokecrystal, pokered, and hacks based on them like Polished Crystal.
+ pkgver = 299.3069954
+ pkgrel = 1
+ url = https://github.com/Rangi42/polished-map
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = unzip
+ depends = libxft
+ depends = libxpm
+ source = git+ssh://git@github.com/Rangi42/polished-map.git
+ sha1sums = SKIP
+
+pkgname = polished-map-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ad93f4f24f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jakub Kądziołka <kuba@kadziolka.net>
+
+pkgname=polished-map-git
+pkgdesc="A map and tileset editor for pokecrystal, pokered, and hacks based on them like Polished Crystal."
+pkgver=299.3069954
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/Rangi42/polished-map"
+license=(LGPL3)
+depends=(libxft libxpm)
+makedepends=(git unzip)
+source=(git+ssh://git@github.com/Rangi42/polished-map.git)
+sha1sums=(SKIP)
+
+pkgver(){
+ cd polished-map
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare(){
+ cd polished-map/lib
+ unzip fltk-1.3.5.zip
+ chmod +x fltk-1.3.5/configure
+}
+
+build(){
+ # Build FLTK with the latest ABI enabled
+ cd polished-map/lib/fltk-1.3.5
+ ./configure --prefix="$PWD/.." --with-abiversion=10305
+ make
+ make install
+ cd ../..
+ PATH="$PWD/lib/bin:$PATH" make
+}
+
+package(){
+ cd polished-map
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}