summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-08-19 19:04:45 +0200
committerFabioLolix2020-08-19 19:04:45 +0200
commitd744732b17bb4fa417ae5a1bee953e505db53b92 (patch)
tree6b56d5bd433be000766c081be47ac23bade417a1
parent82cb174564995b65f9fdf0a7e0a8b0957dd13866 (diff)
downloadaur-polo.tar.gz
fix build
-rwxr-xr-x.SRCINFO6
-rw-r--r--0001-Re-add-support-for-vte291-0.52.patch25
-rwxr-xr-xPKGBUILD11
3 files changed, 11 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ab999c69878..c0faff7d009f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polo
pkgdesc = A modern, light-weight GTK file manager for Linux, currently in beta
pkgver = 18.8.3
- pkgrel = 1
+ pkgrel = 2
url = https://teejee2008.github.io/polo/
arch = 686
arch = x86_64
@@ -24,9 +24,11 @@ pkgbase = polo
optdepends = lzop
optdepends = polo-donation-plugins
source = polo-18.8.3-538be6950d9394c90aa90be3973a3c8d9a27b999.tar.gz::https://github.com/teejee2008/polo/archive/538be6950d9394c90aa90be3973a3c8d9a27b999.tar.gz
- source = 0001-Re-add-support-for-vte291-0.52.patch
+ source = https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/polo-Re-add-support-for-vte291-0.52.patch
+ source = https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/polo-fix-build.patch
sha256sums = ac96ad931024d7b96d5458f963753bf2bc92dc697dbfe5bb8bbc90aa98824443
sha256sums = 4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f
+ sha256sums = 895c7f21844fead0df7b044396ee972f55cd03e4cb5a218adc30e1605e274f45
pkgname = polo
diff --git a/0001-Re-add-support-for-vte291-0.52.patch b/0001-Re-add-support-for-vte291-0.52.patch
deleted file mode 100644
index 649704608c31..000000000000
--- a/0001-Re-add-support-for-vte291-0.52.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d73eda26423ef9730eded03c78c636bebe971948 Mon Sep 17 00:00:00 2001
-From: FabioLolix <fabio.lolix@gmail.com>
-Date: Mon, 13 Aug 2018 01:44:37 +0200
-Subject: [PATCH] Re-add support for vte291 >0.52
-
----
- src/Gtk/TermBox.vala | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Gtk/TermBox.vala b/src/Gtk/TermBox.vala
-index da5d3a0..0c7b37c 100644
---- a/src/Gtk/TermBox.vala
-+++ b/src/Gtk/TermBox.vala
-@@ -255,7 +255,7 @@ public class TermBox : Gtk.Box {
-
- #else
-
-- term.feed_child(cmd, -1);
-+ term.feed_child(cmd.to_utf8());
-
- #endif
- }
---
-2.18.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 8026b9d3ed09..f22d0fe3a29d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=polo
-pkgrel=1
pkgver=18.8.3
+pkgrel=2
pkgdesc="A modern, light-weight GTK file manager for Linux, currently in beta"
arch=(686 x86_64)
url="https://teejee2008.github.io/polo/"
@@ -20,13 +20,16 @@ optdepends=('mediainfo: read media properties from audio and video files'
'polo-donation-plugins')
_commit=538be6950d9394c90aa90be3973a3c8d9a27b999
source=("${pkgname}-${pkgver}-${_commit}.tar.gz::https://github.com/teejee2008/polo/archive/${_commit}.tar.gz"
- '0001-Re-add-support-for-vte291-0.52.patch')
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/polo-Re-add-support-for-vte291-0.52.patch"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/polo-fix-build.patch")
sha256sums=('ac96ad931024d7b96d5458f963753bf2bc92dc697dbfe5bb8bbc90aa98824443'
- '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f')
+ '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f'
+ '895c7f21844fead0df7b044396ee972f55cd03e4cb5a218adc30e1605e274f45')
prepare() {
cd "${pkgname}-${_commit}"
- patch -Np1 -i ../0001-Re-add-support-for-vte291-0.52.patch
+ patch -Np1 -i ../polo-Re-add-support-for-vte291-0.52.patch
+ patch -Np1 -i ../polo-fix-build.patch
}
build() {