summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2023-09-19 11:13:26 +0200
committerGilrain2023-09-19 11:13:26 +0200
commite36579bd014ce88aac3ec91dc239d08a9634d51c (patch)
treee5ac97f7fedfff131298789e7f64f8ed0740704a
parent2204ccb78dd6d30f7e1040015081432a9b2cf5a8 (diff)
downloadaur-pology-git.tar.gz
add pytest
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27bd7e53a886..94e217186bb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = pology-git
pkgdesc = A framework for custom processing of PO files.
- pkgver = 0.13.r5625.91ebf8fb
+ pkgver = 0.13.r5681.4ed65229
pkgrel = 1
url = https://invent.kde.org/sdk/pology
changelog = changelog
arch = any
license = GPL3
+ checkdepends = python-pytest
makedepends = git
makedepends = cmake
makedepends = libxml2
@@ -14,17 +15,13 @@ pkgbase = pology-git
makedepends = python-pygments
depends = python
depends = gettext
- depends = python-pyenchant
- optdepends = python2-dbus: to communicate with external applications
- optdepends = hunspell-lang: a spell-checking dictionary for your language(s)
- optdepends = aspell-lang: a spell-checking dictionary for your language(s)
- optdepends = ispell-lang: a spell-checking dictionary for your language(s)
+ optdepends = python-dbus: to communicate with external applications
+ optdepends = python-pyenchant: for spell checking functionality
optdepends = languagetool: used by the check-grammar sieve
optdepends = apertium: used by the pomtrans script
optdepends = git: for processing files under version control
optdepends = subversion: for processing files under version control
provides = pology
- replaces = pology-svn
options = !makeflags
source = git+https://invent.kde.org/sdk/pology.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2767b0b65321..843b9ab7dc06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname=pology-git
-pkgver=0.13.r5625.91ebf8fb
+pkgver=0.13.r5681.4ed65229
pkgrel=1
pkgdesc='A framework for custom processing of PO files.'
arch=('any')
@@ -9,6 +9,7 @@ license=('GPL3')
url='https://invent.kde.org/sdk/pology'
depends=('python' 'gettext')
makedepends=('git' 'cmake' 'libxml2' 'docbook-xsl' 'libxslt' 'python-pygments')
+checkdepends=('python-pytest')
options=(!makeflags)
optdepends=('python-dbus: to communicate with external applications'
'python-pyenchant: for spell checking functionality'
@@ -33,6 +34,11 @@ build() {
make
}
+check() {
+ cd ${srcdir}/pology
+ python -m pytest
+}
+
package() {
cd ${srcdir}/pology/build
make DESTDIR="${pkgdir}" install