summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Kasak2022-07-04 13:51:46 +0200
committerDenis Kasak2022-07-04 13:51:46 +0200
commit4ac961a0f7fb8840bfe282ab109ec5ad14d89d1a (patch)
tree98b0379a3a129fb8396b27c4d19dba235f17c5db
downloadaur-polyfile-git.tar.gz
Initial commit.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD42
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d90282d4327d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = polyfile-git
+ pkgdesc = A utility to identify and map the semantic structure of files, including polyglots, chimeras, and schizophrenic files.
+ pkgver = 0.4.2.r0.g1ab8d7c
+ pkgrel = 1
+ url = https://github.com/trailofbits/polyfile
+ arch = any
+ license = LGPLv3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-graphviz
+ depends = python-intervaltree
+ depends = python-jinja
+ depends = python-kaitaistruct>=0.7
+ depends = python-networkx
+ depends = python-pdfminer
+ depends = python-pillow>=5.0.0
+ depends = python-yaml>=3.13
+ depends = python-cint-git
+ conflicts = polyfile
+ source = git+https://github.com/trailofbits/polyfile.git#tag=v0.4.2
+ source = git+https://github.com/kaitai-io/kaitai_struct_formats.git
+ source = git+https://github.com/file/file.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = polyfile-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e98e1ff93196
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Denis Kasak <dkasak AT termina DOT org DOT uk>
+
+_pkgname=polyfile
+pkgname="${_pkgname}-git"
+pkgver=0.4.2.r0.g1ab8d7c
+pkgrel=1
+pkgdesc="A utility to identify and map the semantic structure of files, including polyglots, chimeras, and schizophrenic files."
+arch=('any')
+url=https://github.com/trailofbits/polyfile
+license=('LGPLv3')
+depends=('python' 'python-graphviz' 'python-intervaltree' 'python-jinja'
+ 'python-kaitaistruct>=0.7' 'python-networkx' 'python-pdfminer'
+ 'python-pillow>=5.0.0' 'python-yaml>=3.13' 'python-cint-git')
+makedepends=('git' 'python-setuptools')
+conflicts=('polyfile')
+source=("git+https://github.com/trailofbits/${_pkgname}.git#tag=v0.4.2"
+ "git+https://github.com/kaitai-io/kaitai_struct_formats.git"
+ "git+https://github.com/file/file.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git config submodule.kaitai_struct_formats.url "$srcdir/kaitai_struct_formats"
+ git config submodule.file.url "$srcdir/file"
+ git submodule update
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:ts=4:sw=4:et: