summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-21 14:53:20 -0600
committerMark Wagie2024-03-21 14:53:20 -0600
commit10b6ea0e438d680cc2aa230a6b54874e585bd181 (patch)
tree55ddb3acd04367b7dab6e5f2d62e916e7cf72a64
parent0489b4b5e44a0a9c7b37ac3ba7912a0ca5b85939 (diff)
downloadaur-10b6ea0e438d680cc2aa230a6b54874e585bd181.tar.gz
enable LTO, depend on pop-launcher-git
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 750918d7bb4e..205fc3ddf041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = pop-launcher-git
- pkgver = 1.2.1.r51.gb1f6002
+ pkgver = 1.2.1.r56.ga7fc5bc
pkgrel = 1
url = https://github.com/pop-os/launcher
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = pop-launcher-git
depends = dbus
depends = fd
depends = libqalculate
+ depends = pop-icon-theme-git
depends = sh
depends = xdg-utils
- options = !lto
source = git+https://github.com/pop-os/launcher.git
sha256sums = SKIP
@@ -28,6 +28,7 @@ pkgname = pop-launcher-git
pkgname = pop-shell-plugin-system76-power-git
pkgdesc = System76 Power scripts for the launcher
depends = gnome-terminal
+ depends = pop-launcher-git
depends = system76-power
provides = pop-shell-plugin-system76-power
conflicts = pop-shell-plugin-system76-power
diff --git a/PKGBUILD b/PKGBUILD
index a38df6e42fa2..a27a1d58c342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=('pop-launcher-git' 'pop-shell-plugin-system76-power-git')
pkgbase=pop-launcher-git
-pkgver=1.2.1.r51.gb1f6002
+pkgver=1.2.1.r56.ga7fc5bc
pkgrel=1
arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/launcher"
license=('MPL-2.0')
-depends=('dbus' 'fd' 'libqalculate' 'sh' 'xdg-utils')
-makedepends=('cargo' 'git' 'just' 'libegl' 'libxkbcommon')
-options=('!lto')
+depends=(
+ 'dbus'
+ 'fd'
+ 'libqalculate'
+ 'pop-icon-theme-git'
+ 'sh'
+ 'xdg-utils'
+)
+makedepends=(
+ 'cargo'
+ 'git'
+ 'just'
+ 'libegl'
+ 'libxkbcommon'
+)
source=('git+https://github.com/pop-os/launcher.git')
sha256sums=('SKIP')
@@ -24,14 +36,11 @@ prepare() {
just vendor
sed -i 's|{{bin-path}}|/usr/bin/pop-launcher|g' justfile
-
- # change session-lock script icon to one more common
- # so pop-icon-theme is not required
- sed -i 's/locked/object-locked/g' scripts/session/session-lock.sh
}
build() {
cd launcher
+ CFLAGS+=" -ffat-lto-objects"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
just build-vendored
@@ -60,7 +69,7 @@ package_pop-launcher-git() {
package_pop-shell-plugin-system76-power-git() {
pkgdesc="System76 Power scripts for the launcher"
- depends=('gnome-terminal' 'system76-power')
+ depends=('gnome-terminal' 'pop-launcher-git' 'system76-power')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" 'pop-launcher-system76-power')
replaces=('pop-launcher-system76-power-git')