summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastien Traverse2018-02-05 00:58:41 +0100
committerBastien Traverse2018-02-05 01:01:40 +0100
commit2910ea7ec7fe94b1ad2cfd70adc510c80741ef97 (patch)
tree3721adf0208276a7bfad821d8215839771e7e7d9
parent54f02a4e90824b8760d167451c133f83d5a5fce6 (diff)
downloadaur-2910ea7ec7fe94b1ad2cfd70adc510c80741ef97.tar.gz
Switch to CI builds to get fresher versions & fix permissions
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d593e2d76e87..5685087f880e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Feb 4 23:49:44 UTC 2018
pkgbase = popcorntime-bin
- pkgdesc = Stream movies and TV shows from torrents
+ pkgdesc = Stream movies and TV shows from torrents (continuous integration builds)
pkgver = 0.3.10
- pkgrel = 1
+ pkgrel = 2
url = https://popcorntime.sh
arch = i686
arch = x86_64
@@ -20,10 +22,10 @@ pkgbase = popcorntime-bin
options = !strip
source = popcorntime.desktop
sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
- source_i686 = https://get.popcorntime.sh/repo/build/Popcorn-Time-0.3.10-Linux-32.tar.xz
- sha256sums_i686 = c6497b067304918c3d19db2fecd36cc9efe1fff13765d461b24fd2cd8692ed42
- source_x86_64 = https://get.popcorntime.sh/repo/build/Popcorn-Time-0.3.10-Linux-64.tar.xz
- sha256sums_x86_64 = b7f789c2e2f3b0f7e3408a437080404f8a2aa7ce4a41858cf891b02cda8c37a5
+ source_i686 = https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-0.3.10_linux32.tar.xz
+ sha256sums_i686 = 6eb6a16cc40ed199c5e14b9a16f9dbb1bd45174b59a2a93271048ced21a2b618
+ source_x86_64 = https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-0.3.10_linux64.tar.xz
+ sha256sums_x86_64 = 2509fe735b6517f9fec38f9c7f5652840a5ee5a7148e31f813b0946db4bca43e
pkgname = popcorntime-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2b73d45f20ae..0de2302f245b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@
pkgname=popcorntime-bin
_pkgname=popcorntime
pkgver=0.3.10
-pkgrel=1
-pkgdesc="Stream movies and TV shows from torrents"
+pkgrel=2
+pkgdesc="Stream movies and TV shows from torrents (continuous integration builds)"
arch=('i686' 'x86_64')
url="https://popcorntime.sh"
license=('GPL3')
@@ -24,11 +24,14 @@ provides=('popcorntime' 'popcorn-time-ce')
conflicts=('popcorntime')
options=('!strip')
source=("${_pkgname}.desktop")
-source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz")
-source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz")
+## Official releases are lagging behind. Using CI builds instead
+#source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz")
+#source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz")
+source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz")
+source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz")
sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
-sha256sums_i686=('c6497b067304918c3d19db2fecd36cc9efe1fff13765d461b24fd2cd8692ed42')
-sha256sums_x86_64=('b7f789c2e2f3b0f7e3408a437080404f8a2aa7ce4a41858cf891b02cda8c37a5')
+sha256sums_i686=('6eb6a16cc40ed199c5e14b9a16f9dbb1bd45174b59a2a93271048ced21a2b618')
+sha256sums_x86_64=('2509fe735b6517f9fec38f9c7f5652840a5ee5a7148e31f813b0946db4bca43e')
package() {
install -dm755 "${pkgdir}/usr/share/${_pkgname}"
@@ -48,4 +51,8 @@ package() {
# Copy complete content of source archive to /usr/share/${_pkgname}/
cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}/"
+
+ # Fix permissions
+ find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \;
+ find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \;
}