summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Popper2016-02-14 10:27:31 -0500
committerAriel Popper2016-02-14 10:27:31 -0500
commit737b1f91cb110f9f93c2ec1a052a672a795641c2 (patch)
treeeee7a87ce6d8e484c648f46591957d64344e27d3
downloadaur-737b1f91cb110f9f93c2ec1a052a672a795641c2.tar.gz
9.4.6
-rw-r--r--.SRCINFO67
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD161
-rw-r--r--postgresql-check-db-dir49
-rw-r--r--postgresql-run-socket.patch12
-rw-r--r--postgresql.install26
-rw-r--r--postgresql.logrotate4
-rw-r--r--postgresql.pam3
-rw-r--r--postgresql.service31
-rw-r--r--postgresql.tmpfiles.conf1
10 files changed, 357 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c4935f53008
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,67 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 15:25:37 UTC 2016
+pkgbase = postgresql-lts
+ pkgdesc = A sophisticated object-relational DBMS
+ pkgver = 9.4.6
+ pkgrel = 1
+ url = http://www.postgresql.org/
+ arch = i686
+ arch = x86_64
+ license = custom:PostgreSQL
+ makedepends = krb5
+ makedepends = libxml2
+ makedepends = python2
+ makedepends = perl
+ makedepends = tcl>=8.6.0
+ makedepends = openssl>=1.0.0
+ makedepends = pam
+ source = http://ftp.postgresql.org/pub/source/v9.4.6/postgresql-9.4.6.tar.bz2
+ source = postgresql-run-socket.patch
+ source = postgresql.pam
+ source = postgresql.logrotate
+ source = postgresql.service
+ source = postgresql.tmpfiles.conf
+ source = postgresql-check-db-dir
+ sha256sums = cbce1f4d01a6142c5d8bebe125623c5198ec04f363da7dd3d3b3a4100b4140a6
+ sha256sums = 8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9
+ sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
+ sha256sums = 6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e
+ sha256sums = 456c331d10b987c2bb7b4a9b42192ffae5b6b2c72829d16b20f39c5897b79d62
+ sha256sums = 7e086d70e0dcaa6ce45693b4e826ce92d770192b3aff5642319b1ef279d88dc4
+ sha256sums = f15418433b7d9a153eea22af58cc64fda462144d7039d1083ae1e2e489cc303a
+
+pkgname = postgresql-lts-libs
+ pkgdesc = Libraries for use with PostgreSQL
+ depends = krb5
+ depends = openssl>=1.0.0
+ depends = readline>=6.0
+ provides = postgresql-client
+ provides = postgresql-libs=9.4
+ conflicts = postgresql-client
+ conflicts = postgresql-libs
+
+pkgname = postgresql-lts-docs
+ pkgdesc = HTML documentation for PostgreSQL
+ arch = any
+ provides = postgresql-docs=9.4
+ conflicts = postgresql-docs
+ options = docs
+
+pkgname = postgresql-lts
+ install = postgresql.install
+ depends = postgresql-lts-libs>=9.4.6
+ depends = krb5
+ depends = libxml2
+ depends = readline>=6.0
+ depends = openssl>=1.0.0
+ depends = pam
+ optdepends = python2: for PL/Python support
+ optdepends = perl: for PL/Perl support
+ optdepends = tcl: for PL/Tcl support
+ optdepends = postgresql-lts-old-upgrade: upgrade from previous major version using pg_upgrade
+ provides = postgresql=9.4
+ conflicts = postgresql
+ options = staticlibs
+ backup = etc/pam.d/postgresql
+ backup = etc/logrotate.d/postgresql
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16613a311914
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,161 @@
+# Maintainer: Ariel Popper <a@arielp.com>
+
+pkgbase=postgresql-lts
+pkgname=('postgresql-lts-libs' 'postgresql-lts-docs' 'postgresql-lts')
+pkgver=9.4.6
+_majorver=${pkgver%.*}
+pkgrel=1
+pkgdesc="A sophisticated object-relational DBMS"
+arch=('i686' 'x86_64')
+url="http://www.postgresql.org/"
+license=('custom:PostgreSQL')
+makedepends=('krb5' 'libxml2' 'python2' 'perl' 'tcl>=8.6.0'
+ 'openssl>=1.0.0' 'pam')
+source=(http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
+ postgresql-run-socket.patch postgresql.pam postgresql.logrotate
+ postgresql.service postgresql.tmpfiles.conf
+ postgresql-check-db-dir)
+sha256sums=('cbce1f4d01a6142c5d8bebe125623c5198ec04f363da7dd3d3b3a4100b4140a6'
+ '8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e'
+ '456c331d10b987c2bb7b4a9b42192ffae5b6b2c72829d16b20f39c5897b79d62'
+ '7e086d70e0dcaa6ce45693b4e826ce92d770192b3aff5642319b1ef279d88dc4'
+ 'f15418433b7d9a153eea22af58cc64fda462144d7039d1083ae1e2e489cc303a')
+
+build() {
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ patch -Np1 < ../postgresql-run-socket.patch
+
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man \
+ --datadir=/usr/share/postgresql --sysconfdir=/etc --with-gssapi \
+ --with-libxml --with-openssl --with-perl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl --with-pam --with-system-tzdata=/usr/share/zoneinfo \
+ --with-uuid=e2fs --enable-nls --enable-thread-safety
+
+ make world
+}
+
+package_postgresql-lts-libs() {
+ pkgdesc="Libraries for use with PostgreSQL"
+ depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0')
+ provides=('postgresql-client' "postgresql-libs=$_majorver")
+ conflicts=('postgresql-client' 'postgresql-libs')
+
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install license
+ install -D -m644 COPYRIGHT \
+ "${pkgdir}/usr/share/licenses/${pkgbase}-libs/LICENSE"
+
+ # install libs and non-server binaries
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump \
+ src/bin/psql src/bin/scripts; do
+ make -C ${dir} DESTDIR="${pkgdir}" install
+ done
+
+ for util in pg_config pg_dump pg_dumpall pg_restore psql clusterdb \
+ createdb createlang createuser dropdb droplang dropuser \
+ pg_isready reindexdb vacuumdb; do
+ install -D -m644 doc/src/sgml/man1/${util}.1 \
+ "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
+
+ cd src/include
+
+ mkdir -p "${pkgdir}"/usr/include/{libpq,postgresql/internal/libpq}
+
+ # these headers are needed by the public headers of the interfaces
+ install -m644 pg_config.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_os.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_ext.h "${pkgdir}/usr/include/"
+ install -m644 postgres_ext.h "${pkgdir}/usr/include/"
+ install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
+ install -m644 pg_config_manual.h "${pkgdir}/usr/include/"
+
+ # these headers are needed by the not-so-public headers of the interfaces
+ install -m644 c.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 port.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq/"
+}
+
+package_postgresql-lts-docs() {
+ pkgdesc="HTML documentation for PostgreSQL"
+ arch=('any')
+ provides=("postgresql-docs=${_majorver}")
+ conflicts=('postgresql-docs')
+ options=('docs')
+
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install license
+ install -D -m644 COPYRIGHT \
+ "${pkgdir}/usr/share/licenses/${pkgbase}-docs/LICENSE"
+
+ make -C doc/src/sgml DESTDIR="${pkgdir}" install-html
+ chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html/"
+
+ # clean up
+ rmdir "${pkgdir}"/usr/share/man/man{1,3,7}
+ rmdir "${pkgdir}"/usr/share/man
+}
+
+package_postgresql-lts() {
+ #pkgdesc="" ##Set at top so namcap will just shut the hell up already!
+ provides=("postgresql=$_majorver")
+ conflicts=("postgresql")
+ backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
+ depends=("postgresql-lts-libs>=${pkgver}" 'krb5' 'libxml2' \
+ 'readline>=6.0' 'openssl>=1.0.0' 'pam')
+ optdepends=('python2: for PL/Python support'
+ 'perl: for PL/Perl support'
+ 'tcl: for PL/Tcl support'
+ 'postgresql-lts-old-upgrade: upgrade from previous major version using pg_upgrade')
+ options=('staticlibs')
+ install=postgresql.install
+
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install
+ make DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+ make -C doc/src/sgml DESTDIR="${pkgdir}" install-man
+
+ # we don't want these, they are in the -libs package
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump \
+ src/bin/psql src/bin/scripts; do
+ make -C ${dir} DESTDIR="${pkgdir}" uninstall
+ done
+ for util in pg_config pg_dump pg_dumpall pg_restore psql clusterdb \
+ createdb createlang createuser dropdb droplang dropuser \
+ pg_isready reindexdb vacuumdb; do
+ rm "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
+
+ # install license
+ install -D -m644 COPYRIGHT \
+ "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+
+ # clean up unneeded installed items
+ rm -rf "${pkgdir}/usr/include/postgresql/internal"
+ rm -rf "${pkgdir}/usr/include/libpq"
+ find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
+ rmdir "${pkgdir}/usr/share/doc/postgresql/html"
+
+ install -D -m644 "${srcdir}/postgresql.tmpfiles.conf" \
+ "${pkgdir}/usr/lib/tmpfiles.d/postgresql.conf"
+ install -D -m644 "${srcdir}/postgresql.service" \
+ "${pkgdir}/usr/lib/systemd/system/postgresql.service"
+ install -D -m755 "${srcdir}/postgresql-check-db-dir" \
+ "${pkgdir}/usr/bin/postgresql-check-db-dir"
+
+ install -D -m644 "${srcdir}/postgresql.pam" \
+ "${pkgdir}/etc/pam.d/postgresql"
+
+ install -D -m644 "${srcdir}/postgresql.logrotate" \
+ "${pkgdir}/etc/logrotate.d/postgresql"
+}
diff --git a/postgresql-check-db-dir b/postgresql-check-db-dir
new file mode 100644
index 000000000000..540f1780643e
--- /dev/null
+++ b/postgresql-check-db-dir
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# This script verifies that the postgresql data directory has been correctly
+# initialized. We do not want to automatically initdb it, because that has
+# a risk of catastrophic failure (ie, overwriting a valuable database) in
+# corner cases, such as a remotely mounted database on a volume that's a
+# bit slow to mount. But we can at least emit a message advising newbies
+# what to do.
+
+PGDATA="$1"
+
+if [ -z "$PGDATA" ]
+then
+ echo "Usage: $0 database-path"
+ exit 1
+fi
+
+# PGMAJORVERSION is major version
+PGMAJORVERSION=9.4
+# PREVMAJORVERSION is the previous major version, e.g., 8.4, for upgrades
+PREVMAJORVERSION=9.3
+
+# Check for the PGDATA structure
+if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` = x"$PGMAJORVERSION" ]
+ then
+ : A-OK
+ elif [ x`cat "$PGDATA/PG_VERSION"` = x"$PREVMAJORVERSION" ]
+ then
+ echo $"An old version of the database format was found."
+ echo $"See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL"
+ exit 1
+ else
+ echo $"An old version of the database format was found."
+ echo $"You need to dump and reload before using PostgreSQL $PGMAJORVERSION."
+ echo $"See http://www.postgresql.org/docs/$PGMAJORVERSION/static/upgrading.html"
+ exit 1
+ fi
+else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo $"\"$PGDATA\" is missing or empty. Use a command like"
+ echo $" su - postgres -c \"initdb --locale en_US.UTF-8 -D '$PGDATA'\""
+ echo $"with relevant options, to initialize the database cluster."
+ exit 1
+fi
+
+exit 0
diff --git a/postgresql-run-socket.patch b/postgresql-run-socket.patch
new file mode 100644
index 000000000000..b558c7b74961
--- /dev/null
+++ b/postgresql-run-socket.patch
@@ -0,0 +1,12 @@
+diff -Naur postgresql-9.2.0.sockets/src/include/pg_config_manual.h postgresql-9.2.0/src/include/pg_config_manual.h
+--- postgresql-9.2.0.sockets/src/include/pg_config_manual.h 2012-09-06 17:26:17.000000000 -0400
++++ postgresql-9.2.0/src/include/pg_config_manual.h 2012-09-06 18:13:18.183092471 -0400
+@@ -144,7 +144,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
diff --git a/postgresql.install b/postgresql.install
new file mode 100644
index 000000000000..c8302dcecb50
--- /dev/null
+++ b/postgresql.install
@@ -0,0 +1,26 @@
+post_install() {
+ if [ ! -d '/var/lib/postgres' ]; then
+ mkdir -p '/var/lib/postgres'
+ fi
+ if ! getent group postgres >/dev/null; then
+ groupadd -g 88 postgres
+ fi
+ if ! getent passwd postgres >/dev/null; then
+ useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
+ passwd -l postgres >/dev/null
+ fi
+ systemd-tmpfiles --create postgresql.conf
+ if [ ! -d '/var/lib/postgres/data' ]; then
+ mkdir -p '/var/lib/postgres/data'
+ chown postgres:postgres '/var/lib/postgres/data'
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+ # FS#23858, fix postgres user shell issue
+ postgres_shell=$(getent passwd postgres | cut -d: -f7)
+ if [ "$postgres_shell" = "/sbin/nologin" ]; then
+ chsh -s /bin/bash postgres
+ fi
+}
diff --git a/postgresql.logrotate b/postgresql.logrotate
new file mode 100644
index 000000000000..9c36918be5e5
--- /dev/null
+++ b/postgresql.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}
diff --git a/postgresql.pam b/postgresql.pam
new file mode 100644
index 000000000000..53724d1f86a7
--- /dev/null
+++ b/postgresql.pam
@@ -0,0 +1,3 @@
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/postgresql.service b/postgresql.service
new file mode 100644
index 000000000000..f4a871ad61a1
--- /dev/null
+++ b/postgresql.service
@@ -0,0 +1,31 @@
+[Unit]
+Description=PostgreSQL database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/postgres
+
+SyslogIdentifier=postgres
+PIDFile=/var/lib/postgres/data/postmaster.pid
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+# Additional security-related features
+PrivateTmp=true
+ProtectSystem=full
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target
diff --git a/postgresql.tmpfiles.conf b/postgresql.tmpfiles.conf
new file mode 100644
index 000000000000..c2e0747dae63
--- /dev/null
+++ b/postgresql.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/postgresql 0775 postgres postgres -