summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Sharpe2019-05-18 22:25:40 -0700
committerJeff Sharpe2019-05-18 22:25:40 -0700
commit98e1578aaffad3a626784099018a6a42f0462972 (patch)
tree2915f101113c6b24fc7554d33e474c12c39059ed
downloadaur-postgresql-scram256-password-generator.tar.gz
Creating new package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD47
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..197e1e0bfc41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = postgresql-scram256-password-generator
+ pkgdesc = A program to generate password hashes using SCRAM-SHA-256 for PostgreSQL 10 (and above).
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/DenisMedeirosBBD/PostgresSCRAM256PasswordGenerator
+ arch = x86_64
+ license = GPL2
+ makedepends = autoconf
+ makedepends = automake
+ depends = postgresql-libs
+ provides = pg-password-generator
+ source = https://github.com/DenisMedeirosBBD/PostgresSCRAM256PasswordGenerator/archive/1.0.tar.gz
+ md5sums = 04926346bcd623a1a6d8f0ef22ec2693
+
+pkgname = postgresql-scram256-password-generator
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0fbf3b8a15b4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.tar.gz
+tags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fbd13902715
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: olddog <jeff@impcode.com>
+
+pkgname=postgresql-scram256-password-generator
+_realname=postgresql-scram256-password-generator
+pkgver=1.0
+pkgrel=1
+pkgdesc="A program to generate password hashes using SCRAM-SHA-256 for PostgreSQL 10 (and above)."
+arch=('x86_64')
+url="https://github.com/DenisMedeirosBBD/PostgresSCRAM256PasswordGenerator"
+license=('GPL2')
+depends=('postgresql-libs')
+makedepends=('autoconf' 'automake')
+provides=('pg-password-generator')
+
+source=(
+ "https://github.com/DenisMedeirosBBD/PostgresSCRAM256PasswordGenerator/archive/${pkgver}.tar.gz"
+)
+
+md5sums=('04926346bcd623a1a6d8f0ef22ec2693')
+
+prepare()
+{
+ cd "${srcdir}/PostgresSCRAM256PasswordGenerator-${pkgver}"
+ autoreconf -iv
+ ./configure --prefix="${pkgdir}/usr/bin"
+}
+
+build()
+{
+ cd "${srcdir}/PostgresSCRAM256PasswordGenerator-${pkgver}"
+ make
+}
+
+package()
+{
+ # install documentation
+ cd "${srcdir}/PostgresSCRAM256PasswordGenerator-${pkgver}"
+ install -Dm 0644 AUTHORS -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 0644 ChangeLog -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 0644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # install LICENSE file
+ install -Dm 0644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # install binary file
+ make install
+}