summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-05-15 10:03:04 -0400
committerKyle Sferrazza2017-05-15 10:03:04 -0400
commit1dcd704e1f0f38e84c77232640c8b1cb5d1581b2 (patch)
treea41c7a7895516a202ba9abbe79d0f651630197b0
parent8691190cfc69c28b4b555bfdf4522c7aa8110f51 (diff)
downloadaur-1dcd704e1f0f38e84c77232640c8b1cb5d1581b2.tar.gz
prepare for dotnet 2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD28
-rwxr-xr-xbuild.sh20
3 files changed, 16 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 065a77b3987c..bae392da5a6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell-git
pkgdesc = A cross-platform automation and configuration tool/framework
- pkgver = 6.0.0.alpha.17.17.g3f274aad
+ pkgver = 6.0.0.beta.1.10.g2d06c170
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
arch = x86_64
@@ -8,21 +8,18 @@ pkgbase = powershell-git
makedepends = git
makedepends = cmake
makedepends = proot
- makedepends = dotnet
+ makedepends = dotnet>=2.0
depends = bash
- depends = icu55
+ depends = icu
provides = powershell
- conflicts = powershell
source = powershell::git+https://github.com/PowerShell/PowerShell.git
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
source = os-release
- source = build.sh
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = f5841baa62b1322c07f9394940cec818
- md5sums = d20378ea8504200919c65de6592f0b24
pkgname = powershell-git
diff --git a/PKGBUILD b/PKGBUILD
index 5aa7879629c2..303b7124a96a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,23 @@
pkgname='powershell-git'
_pkgname='powershell'
-pkgver=6.0.0.alpha.17.17.g3f274aad
+pkgver=6.0.0.beta.1.10.g2d06c170
pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
-makedepends=('git' 'cmake' 'proot' 'dotnet')
-depends=('bash' 'icu55')
-conflicts=('powershell')
+makedepends=('git' 'cmake' 'proot' 'dotnet>=2.0')
+depends=('bash' 'icu')
provides=('powershell')
source=($_pkgname::'git+https://github.com/PowerShell/PowerShell.git'
'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
'googletest::git+https://github.com/google/googletest.git'
- 'os-release'
- 'build.sh')
+ 'os-release')
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'f5841baa62b1322c07f9394940cec818'
- 'd20378ea8504200919c65de6592f0b24')
+ 'f5841baa62b1322c07f9394940cec818')
pkgver() {
cd $_pkgname
@@ -49,7 +46,7 @@ build() {
popd
PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/build.sh
+ proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/powershell/build.sh
}
check() {
@@ -62,14 +59,15 @@ check() {
package() {
- cd $_pkgname/src/powershell-unix
+ cd $pkgname/src/powershell-unix
- mkdir -p "$pkgdir"/usr/lib/$_pkgname
- cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$_pkgname
+ mkdir -p "$pkgdir"/usr/lib/$pkgname
+ cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$pkgname
+ chmod +x "$pkgdir"/usr/lib/$pkgname
- mkdir -p "$pkgdir"/usr/share/licenses/$_pkgname
- cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$_pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
+ ln -s "$pkgdir"/usr/lib/$pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
}
diff --git a/build.sh b/build.sh
deleted file mode 100755
index de97396b2159..000000000000
--- a/build.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/usr/bin/env bash
-
-dotnet restore
-
-pushd src/ResGen
-dotnet run -c Linux
-popd
-
-pushd src/TypeCatalogParser
-dotnet run -c Linux
-popd
-
-pushd src/TypeCatalogGen
-dotnet run -c Linux ../Microsoft.PowerShell.CoreCLR.AssemblyLoadContext/CorePsTypeCatalog.cs powershell.inc
-popd
-
-cd src/powershell-unix
-dotnet build -c Linux && dotnet publish --no-build -c Linux
-
-# vim:set ts=2 sw=2 et: