summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2016-09-05 21:15:51 -0400
committerSergio Correia2016-09-05 21:19:01 -0400
commit2c665905c93c4b349cbf397282656405f2611288 (patch)
tree3abaae4cf33e74e704dba14c6415e792898f9a98
parent904f011de8a27b483d2a05dd18acfda3c7dd2dd7 (diff)
downloadaur-2c665905c93c4b349cbf397282656405f2611288.tar.gz
Revert c695d41 conditionally, depending on dotnet-cli version
Starting in dotnet-cli build 3546, the packages are placed in lowercased directory names. For now, we revert c695d41 if we are using an older dotnet-cli version. Fragile, but might do while we think on a better way to address this.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rwxr-xr-xbuild.sh4
-rw-r--r--revert-commit-c695d41.patch21
4 files changed, 48 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6db5612dc01b..5745ffeeb000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.0.1
-# Tue Aug 30 16:42:53 UTC 2016
+# Tue Sep 6 01:15:13 UTC 2016
pkgbase = powershell-git
pkgdesc = A cross-platform automation and configuration tool/framework.
- pkgver = 6.0.0.alpha.9.192.g901af51
- pkgrel = 2
+ pkgver = 6.0.0.alpha.9.247.g0c4472e
+ pkgrel = 1
url = https://github.com/PowerShell/PowerShell
arch = x86_64
license = MIT
@@ -18,10 +18,12 @@ pkgbase = powershell-git
conflicts = powershell-bin
source = powershell::git://github.com/PowerShell/PowerShell.git
source = os-release
+ source = revert-commit-c695d41.patch
source = build.sh
sha256sums = SKIP
sha256sums = e903a41166648f2e6113dff83b116e9ed6a5dc7d302ac24ae26811583bcb9cc2
- sha256sums = deb50de5aec78f17b818897b783028a0809ab9b508074772470622d8f6ffd048
+ sha256sums = 4568c69cf2a0a961d3f16c069b24391dea7898cd7c856cad94b70a73ef6a9224
+ sha256sums = 190dfc2b3b0bbc49db8411c3b934f460cf9d1399e30e93a5ff50e9b33613428b
pkgname = powershell-git
diff --git a/PKGBUILD b/PKGBUILD
index da65f73232b0..20c798e692cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname='powershell-git'
_pkgname='powershell'
-pkgver=6.0.0.alpha.9.192.g901af51
-pkgrel=2
+pkgver=6.0.0.alpha.9.247.g0c4472e
+pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework."
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
@@ -14,10 +14,12 @@ conflicts=('powershell' 'powershell-bin')
provides=('powershell')
source=($_pkgname::'git://github.com/PowerShell/PowerShell.git'
'os-release'
+ 'revert-commit-c695d41.patch'
'build.sh')
sha256sums=('SKIP'
'e903a41166648f2e6113dff83b116e9ed6a5dc7d302ac24ae26811583bcb9cc2'
- 'deb50de5aec78f17b818897b783028a0809ab9b508074772470622d8f6ffd048')
+ '4568c69cf2a0a961d3f16c069b24391dea7898cd7c856cad94b70a73ef6a9224'
+ '190dfc2b3b0bbc49db8411c3b934f460cf9d1399e30e93a5ff50e9b33613428b')
pkgver() {
cd "${_pkgname}"
@@ -27,6 +29,19 @@ pkgver() {
prepare() {
cd "${_pkgname}"
git submodule update --init
+
+ # Starting off clean.
+ git clean -dfx
+ rm -rf ~/.nuget
+
+ # Workaround due to
+ # https://github.com/PowerShell/PowerShell/commit/c695d41c47c8baa48db1a590fe7378641a9e0ab9
+ net_version=$(dotnet --version)
+ net_build_number=${net_version##*-}
+ if [[ "${build_number}" -lt "3546" ]]; then
+ msg "Reverting powershell commit c695d41"
+ patch -p1 < ../revert-commit-c695d41.patch
+ fi
}
build() {
@@ -37,8 +52,6 @@ build() {
make
popd
- dotnet restore
-
proot -b "${srcdir}/os-release":/etc/os-release "${srcdir}/build.sh"
}
diff --git a/build.sh b/build.sh
index 89b5550c51c0..de97396b2159 100755
--- a/build.sh
+++ b/build.sh
@@ -1,5 +1,7 @@
#!/usr/bin/env bash
+dotnet restore
+
pushd src/ResGen
dotnet run -c Linux
popd
@@ -13,6 +15,6 @@ dotnet run -c Linux ../Microsoft.PowerShell.CoreCLR.AssemblyLoadContext/CorePsT
popd
cd src/powershell-unix
-dotnet -v build -c Linux && dotnet publish --no-build -c Linux
+dotnet build -c Linux && dotnet publish --no-build -c Linux
# vim:set ts=2 sw=2 et:
diff --git a/revert-commit-c695d41.patch b/revert-commit-c695d41.patch
new file mode 100644
index 000000000000..9dc03085dd9b
--- /dev/null
+++ b/revert-commit-c695d41.patch
@@ -0,0 +1,21 @@
+commit 2618e4421663f0f6edb6598e417b9be47a868ac5
+Author: Sergio Correia <sergio@correia.cc>
+Date: Mon Sep 5 20:16:53 2016 -0400
+
+ Revert "Use lowercase name for package folders (#2162)"
+
+ This reverts commit c695d41c47c8baa48db1a590fe7378641a9e0ab9.
+
+diff --git a/src/TypeCatalogParser/Main.cs b/src/TypeCatalogParser/Main.cs
+index 91ec7e9..3e7f07b 100644
+--- a/src/TypeCatalogParser/Main.cs
++++ b/src/TypeCatalogParser/Main.cs
+@@ -34,7 +34,7 @@ namespace TypeCatalogParser
+ // Get the real reference assemblies
+ from y in x.CompileTimeAssemblies where y.Path.EndsWith(".dll")
+ // Construct the path to the assemblies
+- select $"{context.PackagesDirectory}/{x.Name.ToLower()}/{x.Version}/{y.Path};");
++ select $"{context.PackagesDirectory}/{x.Name}/{x.Version}/{y.Path};");
+
+ Console.WriteLine($"List of reference assemblies written to {outputPath}");
+ }