summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2018-09-25 15:49:21 -0400
committerKyle Sferrazza2018-09-25 15:49:21 -0400
commit3e3297e245ad0524e6c69026ca136df4bae6c609 (patch)
treed14179cd1a984bde42ec7bbf5e63983ef1469cdf
parentdb761b0099f51064c2e925ca662190b43a993e3e (diff)
downloadaur-3e3297e245ad0524e6c69026ca136df4bae6c609.tar.gz
v6.1.0
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD43
-rwxr-xr-xbuild.sh20
4 files changed, 35 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc1aa1f3c536..8a508db7f7a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell-git
pkgdesc = A cross-platform automation and configuration tool/framework (git version)
- pkgver = 6.0.1.274.g876085c6f
+ pkgver = 6.1.0.61.g4926e1598
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
@@ -11,6 +11,7 @@ pkgbase = powershell-git
makedepends = dotnet-sdk>=2.0
depends = icu
depends = libunwind
+ depends = openssl-1.0
provides = powershell
conflicts = powershell
source = powershell::git+https://github.com/PowerShell/PowerShell.git
@@ -20,7 +21,7 @@ pkgbase = powershell-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = a0d7e3fa753f74e9722f71a5ab3da6d9
+ md5sums = 2ddd2c3b33c7df1c85f49fa6f7763566
pkgname = powershell-git
diff --git a/.gitignore b/.gitignore
index 190df19fe008..a53893c577e2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
googletest/
pester/
pkg/
-*.xz
+*.pkg.tar
*.gz
powershell/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 53e045a11e5a..01cd09dca0b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname='powershell-git'
_pkgname='powershell'
binaryname='pwsh'
-pkgver=6.0.1.274.g876085c6f
+pkgver=6.1.0.61.g4926e1598
pkgrel=1
pkgdesc='A cross-platform automation and configuration tool/framework (git version)'
arch=('x86_64')
url='https://github.com/PowerShell/PowerShell'
license=('MIT')
makedepends=('git' 'cmake' 'dotnet-sdk>=2.0')
-depends=('icu' 'libunwind')
+depends=('icu' 'libunwind' 'openssl-1.0')
provides=('powershell')
conflicts=('powershell')
source=($_pkgname::'git+https://github.com/PowerShell/PowerShell.git'
- 'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
- 'googletest::git+https://github.com/google/googletest.git'
- build.sh)
+'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
+'googletest::git+https://github.com/google/googletest.git'
+build.sh)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'a0d7e3fa753f74e9722f71a5ab3da6d9')
+ '2ddd2c3b33c7df1c85f49fa6f7763566')
install=powershell.install
pkgver() {
@@ -42,27 +42,28 @@ build() {
TERM=xterm $srcdir/build.sh
}
-check() {
- cd $_pkgname/src/libpsl-native
- make test
-}
+# TODO: pester has moved, and the testing process has changed
+# check() {
+# cd $_pkgname/src/libpsl-native
+# make test
+# }
package() {
- cd $_pkgname/src/powershell-unix
+ cd "$_pkgname/src/powershell-unix"
- mkdir -p $pkgdir/usr/lib/$_pkgname
- cp -a bin/Linux/netcoreapp*/linux-x64 $pkgdir/usr/lib/$_pkgname
+ mkdir -p "$pkgdir/usr/lib/$_pkgname"
+ cp -a "bin/Linux/netcoreapp2.1/linux-x64" "$pkgdir/usr/lib/$_pkgname"
chmod 755 $pkgdir/usr/lib/$_pkgname/linux-x64/$binaryname
- mkdir -p $pkgdir/usr/share/licenses/$pkgname
- cp ../../LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cp "../../LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- mkdir -p $pkgdir/usr/bin
- ln -s /usr/lib/$_pkgname/linux-x64/$binaryname $pkgdir/usr/bin/$binaryname
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/usr/lib/$_pkgname/linux-x64/$binaryname" "$pkgdir/usr/bin/$binaryname"
chmod 644 \
- $pkgdir/usr/lib/powershell/linux-x64/libhostfxr.so \
- $pkgdir/usr/lib/powershell/linux-x64/libhostpolicy.so \
- $pkgdir/usr/lib/powershell/linux-x64/en-US/default.help.txt \
- $pkgdir/usr/lib/powershell/linux-x64/Modules/PSDesiredStateConfiguration/PSDesiredStateConfiguration.psm1
+ "$pkgdir/usr/lib/powershell/linux-x64/libhostfxr.so" \
+ "$pkgdir/usr/lib/powershell/linux-x64/libhostpolicy.so" \
+ "$pkgdir/usr/lib/powershell/linux-x64/en-US/default.help.txt" \
+ "$pkgdir/usr/lib/powershell/linux-x64/Modules/PSDesiredStateConfiguration/PSDesiredStateConfiguration.psm1"
}
diff --git a/build.sh b/build.sh
index 7ac578d797fa..829961df4716 100755
--- a/build.sh
+++ b/build.sh
@@ -9,16 +9,16 @@ dotnet restore src/ResGen
dotnet restore src/TypeCatalogGen
## Setup the build target to gather dependency information
-targetFile="$(pwd)/src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
+targetFile="src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
cat > $targetFile <<-"EOF"
<Project>
- <Target Name="_GetDependencies"
- DependsOnTargets="ResolveAssemblyReferencesDesignTime">
- <ItemGroup>
- <_RefAssemblyPath Include="%(_ReferencesFromRAR.ResolvedPath)%3B" Condition=" '%(_ReferencesFromRAR.Type)' == 'assembly' And '%(_ReferencesFromRAR.PackageName)' != 'Microsoft.Management.Infrastructure' " />
- </ItemGroup>
- <WriteLinesToFile File="$(_DependencyFile)" Lines="@(_RefAssemblyPath)" Overwrite="true" />
- </Target>
+ <Target Name="_GetDependencies"
+ DependsOnTargets="ResolveAssemblyReferencesDesignTime">
+ <ItemGroup>
+ <_RefAssemblyPath Include="%(_ReferencesFromRAR.HintPath)%3B" Condition=" '%(_ReferencesFromRAR.NuGetPackageId)' != 'Microsoft.Management.Infrastructure' "/>
+ </ItemGroup>
+ <WriteLinesToFile File="$(_DependencyFile)" Lines="@(_RefAssemblyPath)" Overwrite="true" />
+ </Target>
</Project>
EOF
dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
@@ -46,6 +46,4 @@ make -j
popd
## Build powershell core
-rawRid="$(dotnet --info | grep RID)"
-rid=${rawRid##* } # retain the part after the last space
-dotnet publish --configuration Linux src/powershell-unix/ --output bin --runtime $rid
+dotnet publish --configuration Linux "src/powershell-unix/" --output bin --runtime "linux-x64"