summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2016-08-21 16:28:06 -0400
committerSergio Correia2016-08-21 16:29:06 -0400
commit7ad5300fea1732e5edcd05b75ce721af5dfe504f (patch)
tree35cd011cc34d42c213dc3164ea5fcd9990bcede7
downloadaur-7ad5300fea1732e5edcd05b75ce721af5dfe504f.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD64
-rwxr-xr-xbuild.sh19
-rw-r--r--os-release9
4 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e717def58bac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by makepkg 5.0.1
+# Sun Aug 21 20:28:11 UTC 2016
+pkgbase = powershell-git
+ pkgdesc = A cross-platform automation and configuration tool/framework.
+ pkgver = 6.0.0.alpha.9.104.g7f82c29
+ pkgrel = 1
+ url = https://github.com/PowerShell/PowerShell
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = proot
+ makedepends = dotnet-cli
+ depends = bash
+ depends = icu55
+ provides = powershell
+ conflicts = powershell
+ conflicts = powershell-bin
+ source = powershell::git://github.com/PowerShell/PowerShell.git
+ source = os-release
+ source = build.sh
+ sha256sums = SKIP
+ sha256sums = e903a41166648f2e6113dff83b116e9ed6a5dc7d302ac24ae26811583bcb9cc2
+ sha256sums = c1c4bb82227190eb78d163eb48c422ed7738dd86d0e0e17b7a445f568540a15c
+
+pkgname = powershell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44c59125e767
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+
+pkgname='powershell-git'
+_pkgname='powershell'
+pkgver=6.0.0.alpha.9.104.g7f82c29
+pkgrel=1
+pkgdesc="A cross-platform automation and configuration tool/framework."
+arch=('i686' 'x86_64')
+url="https://github.com/PowerShell/PowerShell"
+license=('MIT')
+makedepends=('git' 'cmake' 'proot' 'dotnet-cli')
+depends=('bash' 'icu55')
+conflicts=('powershell' 'powershell-bin')
+provides=('powershell')
+source=($_pkgname::'git://github.com/PowerShell/PowerShell.git'
+ 'os-release'
+ 'build.sh')
+sha256sums=('SKIP'
+ 'e903a41166648f2e6113dff83b116e9ed6a5dc7d302ac24ae26811583bcb9cc2'
+ 'c1c4bb82227190eb78d163eb48c422ed7738dd86d0e0e17b7a445f568540a15c')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --tags --long | sed 's/^v//;s/-/./;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "${_pkgname}"
+
+ pushd src/libpsl-native
+ cmake .
+ make
+ popd
+
+ dotnet restore
+
+ proot -b "${srcdir}/os-release":/etc/os-release "${srcdir}/build.sh"
+}
+
+check() {
+ cd "${_pkgname}"/src/libpsl-native
+ make test
+}
+
+
+package() {
+ cd "${_pkgname}"/src/powershell-unix
+
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}"
+ cp -a bin/Linux/netcoreapp1.0/ubuntu.16.04-x64 "${pkgdir}/usr/lib/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp ../../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${pkgname}/ubuntu.16.04-x64/powershell" "${pkgdir}/usr/bin/powershell"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/build.sh b/build.sh
new file mode 100755
index 000000000000..789d497e330e
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+pushd src/ResGen
+dotnet run -c Linux
+popd
+
+pushd src/TypeCatalogParser
+dotnet run -c Linux
+popd
+
+pushd src/TypeCatalogGen
+dotnet run -c Linux ../Microsoft.PowerShell.CoreCLR.AssemblyLoadContext/CorePsTypeCatalog.cs powershell.inc
+popd
+
+cd src/powershell-unix
+dotnet build -c Linux
+dotnet publish
+
+# vim:set ts=2 sw=2 et:
diff --git a/os-release b/os-release
new file mode 100644
index 000000000000..5cff123fce0a
--- /dev/null
+++ b/os-release
@@ -0,0 +1,9 @@
+NAME="Ubuntu"
+VERSION="16.04.1 LTS"
+ID=ubuntu
+ID_LIKE=debian
+PRETTY_NAME="Ubuntu 16.04.1 LTS"
+VERSION_ID="16.04"
+HOME_URL="http://www.ubuntu.com/"
+SUPPORT_URL="http://help.ubuntu.com/"
+BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" \ No newline at end of file