summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlotte Van Petegem2018-08-21 10:04:47 +0200
committerCharlotte Van Petegem2018-08-21 10:04:47 +0200
commit89323a88c4fc9f6c32fd995dcacd085c0de9a5cc (patch)
treec38df348523126aefd651094ed085697eb61df83
parentf2b1780e97c3a01f2b7cbcb92287597241b293da (diff)
downloadaur-89323a88c4fc9f6c32fd995dcacd085c0de9a5cc.tar.gz
Update to 6.0.42
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--exception.patch13
3 files changed, 6 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a82e1cca8c75..af895820a074 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = praat
pkgdesc = A tool for 'Doing Phonetics by computer'
- pkgver = 6.0.41
+ pkgver = 6.0.42
pkgrel = 1
url = http://www.fon.hum.uva.nl/praat/
arch = x86_64
@@ -11,10 +11,8 @@ pkgbase = praat
depends = alsa-lib
depends = gtk2
optdepends = ttf-sil-fonts
- source = https://github.com/praat/praat/archive/v6.0.41.tar.gz
- source = exception.patch
- md5sums = 7c360a7748f87824ec1faf380f7d8313
- md5sums = 29b515b7c6ef133c8fd26fc3c049bbb8
+ source = https://github.com/praat/praat/archive/v6.0.42.tar.gz
+ md5sums = 4f239697138f71dfe2f6c04b9cf68a40
pkgname = praat
diff --git a/PKGBUILD b/PKGBUILD
index fb8bbf241a41..d5028f919baa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Charlotte Van Petegem <charlotte at vanpetegem dot me>
# Maintainer: jpate <jkpate@jkpate.net>
pkgname=praat
-pkgver=6.0.41
+pkgver=6.0.42
pkgrel=1
pkgdesc="A tool for 'Doing Phonetics by computer'"
arch=('x86_64')
@@ -11,14 +11,12 @@ depends=( 'alsa-lib' 'gtk2' )
makedepends=('pkg-config' 'gtk2' 'alsa-lib')
optdepends=( 'ttf-sil-fonts' )
-source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz" "exception.patch")
+source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('7c360a7748f87824ec1faf380f7d8313'
- '29b515b7c6ef133c8fd26fc3c049bbb8')
+md5sums=('4f239697138f71dfe2f6c04b9cf68a40')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 -i ../exception.patch
cp "makefiles/makefile.defs.linux.pulse" "makefile.defs"
}
diff --git a/exception.patch b/exception.patch
deleted file mode 100644
index 3af0dbc839f0..000000000000
--- a/exception.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/stat/PairDistribution.cpp b/stat/PairDistribution.cpp
-index 790a1b88..75da990e 100644
---- a/stat/PairDistribution.cpp
-+++ b/stat/PairDistribution.cpp
-@@ -125,7 +125,7 @@ void PairDistribution_swapInputsAndOutputs (PairDistribution me) {
- }
- }
-
--static double PairDistributions_getTotalWeight_checkPositive (PairDistribution me) throw (MelderError) {
-+static double PairDistributions_getTotalWeight_checkPositive (PairDistribution me) {
- longdouble totalWeight = 0.0;
- for (integer ipair = 1; ipair <= my pairs.size; ipair ++) {
- PairProbability prob = my pairs.at [ipair];