summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn K Pate2015-07-02 11:14:58 +0100
committerJohn K Pate2015-07-02 11:14:58 +0100
commita917da0d0d81e136d592a280030f6b49c5d1ff73 (patch)
tree6f92d66b0277676fe5b55a00f48ea0ccfa5df8e3
downloadaur-a917da0d0d81e136d592a280030f6b49c5d1ff73.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b7d410efb0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = praat
+ pkgdesc = A tool for 'Doing Phonetics by computer'
+ pkgver = 5.4.10
+ pkgrel = 1
+ url = http://www.fon.hum.uva.nl/praat/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = pkg-config
+ depends = alsa-lib
+ depends = gtk2
+ optdepends = ttf-sil-fonts
+ source = http://www.fon.hum.uva.nl/praat/praat5410_sources.tar.gz
+ md5sums = a3b965f7597eefc0273488a6497221b8
+
+pkgname = praat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd63d849960e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: jpate <jkpate@jkpate.net>
+pkgname=praat
+pkgver=5.4.10
+pkgrel=1
+pkgdesc="A tool for 'Doing Phonetics by computer'"
+arch=('x86_64' 'i686')
+url="http://www.fon.hum.uva.nl/praat/"
+license=('GPL')
+depends=( 'alsa-lib' 'gtk2' )
+makedepends=( 'pkg-config' )
+optdepends=( 'ttf-sil-fonts' )
+source=("http://www.fon.hum.uva.nl/praat/praat5410_sources.tar.gz")
+md5sums=('a3b965f7597eefc0273488a6497221b8')
+
+prepare() {
+ cd "$srcdir/sources_5410/"
+
+ cp makefiles/makefile.defs.linux.alsa makefile.defs
+}
+
+build() {
+ cd "$srcdir/sources_5410/"
+
+ make
+}
+
+package() {
+ cd "$srcdir/sources_5410/"
+
+ install -Dm755 praat "$pkgdir/usr/bin/praat"
+}
+