summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlotte Van Petegem2018-08-12 14:01:31 +0200
committerCharlotte Van Petegem2018-08-12 14:01:31 +0200
commitf2b1780e97c3a01f2b7cbcb92287597241b293da (patch)
tree85981661c6fb349a5df9ccf77b1214e8ff76cd08
parent84a61c3789621df0cf32965b39cb3c198cecb85d (diff)
downloadaur-f2b1780e97c3a01f2b7cbcb92287597241b293da.tar.gz
Update to 6.0.41
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--exception.patch13
3 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c25f9952200..a82e1cca8c75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = praat
pkgdesc = A tool for 'Doing Phonetics by computer'
- pkgver = 6.0.40
+ pkgver = 6.0.41
pkgrel = 1
url = http://www.fon.hum.uva.nl/praat/
arch = x86_64
@@ -11,8 +11,10 @@ pkgbase = praat
depends = alsa-lib
depends = gtk2
optdepends = ttf-sil-fonts
- source = https://github.com/praat/praat/archive/v6.0.40.tar.gz
- md5sums = d1cf1590b95a254b83148035a263ca74
+ source = https://github.com/praat/praat/archive/v6.0.41.tar.gz
+ source = exception.patch
+ md5sums = 7c360a7748f87824ec1faf380f7d8313
+ md5sums = 29b515b7c6ef133c8fd26fc3c049bbb8
pkgname = praat
diff --git a/PKGBUILD b/PKGBUILD
index 3dec01eab07c..fb8bbf241a41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Charlotte Van Petegem <charlotte at vanpetegem dot me>
# Maintainer: jpate <jkpate@jkpate.net>
pkgname=praat
-pkgver=6.0.40
+pkgver=6.0.41
pkgrel=1
pkgdesc="A tool for 'Doing Phonetics by computer'"
arch=('x86_64')
@@ -11,12 +11,15 @@ depends=( 'alsa-lib' 'gtk2' )
makedepends=('pkg-config' 'gtk2' 'alsa-lib')
optdepends=( 'ttf-sil-fonts' )
-source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
+source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz" "exception.patch")
-md5sums=('d1cf1590b95a254b83148035a263ca74')
+md5sums=('7c360a7748f87824ec1faf380f7d8313'
+ '29b515b7c6ef133c8fd26fc3c049bbb8')
prepare() {
- cp "$srcdir/$pkgname-$pkgver/makefiles/makefile.defs.linux.pulse" "$srcdir/$pkgname-$pkgver/makefile.defs"
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ../exception.patch
+ cp "makefiles/makefile.defs.linux.pulse" "makefile.defs"
}
build() {
@@ -26,4 +29,4 @@ build() {
package() {
install -Dm755 "$srcdir/$pkgname-$pkgver/praat" "$pkgdir/usr/bin/praat"
-} \ No newline at end of file
+}
diff --git a/exception.patch b/exception.patch
new file mode 100644
index 000000000000..3af0dbc839f0
--- /dev/null
+++ b/exception.patch
@@ -0,0 +1,13 @@
+diff --git a/stat/PairDistribution.cpp b/stat/PairDistribution.cpp
+index 790a1b88..75da990e 100644
+--- a/stat/PairDistribution.cpp
++++ b/stat/PairDistribution.cpp
+@@ -125,7 +125,7 @@ void PairDistribution_swapInputsAndOutputs (PairDistribution me) {
+ }
+ }
+
+-static double PairDistributions_getTotalWeight_checkPositive (PairDistribution me) throw (MelderError) {
++static double PairDistributions_getTotalWeight_checkPositive (PairDistribution me) {
+ longdouble totalWeight = 0.0;
+ for (integer ipair = 1; ipair <= my pairs.size; ipair ++) {
+ PairProbability prob = my pairs.at [ipair];