summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubin Simons2024-01-16 13:29:56 +0100
committerRubin Simons2024-01-16 13:29:56 +0100
commitba826093ce7d4d06e880c7515ada532dc6e28b31 (patch)
tree69162b45ee7ed8579a51005ad2a41965d903da98
downloadaur-pragmatapro-fonts.tar.gz
Initial commit, PragmataPro 0.830.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd87fa7291ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pragmatapro-fonts
+ pkgdesc = A condensed monospaced font optimized for screen, designed by Fabrizio Schiavi to be the ideal font for coding, math and engineering
+ pkgver = 0.830
+ pkgrel = 1
+ url = https://fsd.it/shop/fonts/pragmatapro/
+ arch = any
+ license = custom
+ options = !strip
+ source = local://PPR-zpw12.zip
+ sha256sums = c3f9684c882fc31ef791253960bd97be01da08076968f951b8ac1b8c9a49d98e
+
+pkgname = pragmatapro-fonts
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45cc69646d2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Rubin Simons <me@rubin55.org>
+
+pkgname=pragmatapro-fonts
+pkgver=0.830
+pkgrel=1
+pkgdesc="A condensed monospaced font optimized for screen, designed by Fabrizio Schiavi to be the ideal font for coding, math and engineering"
+url="https://fsd.it/shop/fonts/pragmatapro/"
+arch=(any)
+license=(custom)
+# Note: you need to buy the font at $url and place the zip file in the current or $SRCDEST directory.
+source=('local://PPR-zpw12.zip')
+sha256sums=('c3f9684c882fc31ef791253960bd97be01da08076968f951b8ac1b8c9a49d98e')
+
+options=("!strip")
+
+package() {
+ cd "PragmataPro-Regular${pkgver}"
+ install -Dt "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 *.ttf
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYRIGHT+EULA.txt
+}