summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2021-01-19 13:39:57 +0100
committerFabian Bornschein2021-01-19 13:39:57 +0100
commitfefbdb0ceefb9faf65367050cfd5d2b14fbe5ca3 (patch)
treed3b830fe98acb8ec63bf690932bb0f23f7fd38dd
downloadaur-preconf-sudo-wheel.tar.gz
'Being happy for someone else’s success makes you happier.' ~ Russ Diemon
-rw-r--r--.SRCINFO14
-rw-r--r--71-wheel2
-rw-r--r--PKGBUILD18
-rw-r--r--archlinux.install3
4 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..129d7da7c911
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = preconf-sudo-wheel
+ pkgdesc = configures sudo to allow members of group wheel
+ pkgver = 1
+ pkgrel = 1
+ url = https://wiki.archlinux.org/index.php/Sudo
+ install = archlinux.install
+ arch = any
+ license = MIT
+ depends = sudo
+ source = 71-wheel
+ sha512sums = 158d16583bf2a28d6a2d12ed0b5e87e02b9fc46f5b032650251e377203637cd9baad27274e89e6d886d3f0b32261efd392bcd1c64b2e7559cc6824f944817857
+
+pkgname = preconf-sudo-wheel
+
diff --git a/71-wheel b/71-wheel
new file mode 100644
index 000000000000..e4ec0bb4e6e0
--- /dev/null
+++ b/71-wheel
@@ -0,0 +1,2 @@
+# Allow members of group wheel to execute any command
+%wheel ALL=(ALL) ALL
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c2eedfd543f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Fabian Bornschein <plusfabi-cat-gmail-dog-com>
+pkgname=preconf-sudo-wheel
+pkgver=1
+pkgrel=1
+pkgdesc="configures sudo to allow members of group wheel"
+url='https://wiki.archlinux.org/index.php/Sudo'
+arch=('any')
+license=('MIT')
+depends=('sudo')
+install="archlinux.install"
+source=("71-wheel")
+sha512sums=('158d16583bf2a28d6a2d12ed0b5e87e02b9fc46f5b032650251e377203637cd9baad27274e89e6d886d3f0b32261efd392bcd1c64b2e7559cc6824f944817857')
+
+package() {
+ install -dm 750 "${pkgdir}/etc/sudoers.d"
+ install -Dm 440 "${srcdir}/71-wheel" \
+ "${pkgdir}/etc/sudoers.d/71-wheel"
+}
diff --git a/archlinux.install b/archlinux.install
new file mode 100644
index 000000000000..5f838c3fe91c
--- /dev/null
+++ b/archlinux.install
@@ -0,0 +1,3 @@
+post_install() {
+ printf "\nThanks for using my pkg 😊\n\n"
+}