summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2019-01-07 09:23:40 -0600
committerEric Anderson2019-01-07 09:23:40 -0600
commit562707c44f2d2d59ca9bf0cc439de98f8a082be6 (patch)
treee88c26b235c72832ba6ec5fa6dbbe20d26b16b3d
parentdec7deb03db80354cd98961a45841b59adaef9c5 (diff)
downloadaur-562707c44f2d2d59ca9bf0cc439de98f8a082be6.tar.gz
Add hard dependency on python2-numpy
Upstream's README claims numpy is optional, but it is currently necessary for pronterface. See https://github.com/kliment/Printrun/issues/976 .
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 910213a9a0ce..efcb46dd9aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Mar 9 15:06:26 UTC 2018
pkgbase = printrun
pkgdesc = Pronterface, Pronsole, and Printcore - Pure Python 3D printing host software and GUI
pkgver = 1.6.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/kliment/Printrun
arch = i686
@@ -13,9 +11,9 @@ pkgbase = printrun
depends = python2-pyserial
depends = wxpython
depends = python2-pyglet
+ depends = python2-numpy
optdepends = python2-cairo: to use Projector feature
optdepends = python2-cairosvg: to use Projector feature
- optdepends = python2-numpy: for 3D view
optdepends = python2-dbus: to inhibit sleep when printing
optdepends = python2-psutil: to increase process priority when printing
provides = printrun-git
diff --git a/PKGBUILD b/PKGBUILD
index b0456f764347..d1969a96e225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=printrun
pkgver=1.6.0
-pkgrel=2
+pkgrel=3
epoch=1
_projectname='Printrun'
_gittag="printrun-${pkgver}"
@@ -13,11 +13,10 @@ url='https://github.com/kliment/Printrun'
license=('GPL')
provides=('printrun-git')
conflicts=('printrun-git')
-depends=('python2-pyserial' 'wxpython' 'python2-pyglet')
+depends=('python2-pyserial' 'wxpython' 'python2-pyglet' 'python2-numpy')
optdepends=(
'python2-cairo: to use Projector feature'
'python2-cairosvg: to use Projector feature'
- 'python2-numpy: for 3D view'
'python2-dbus: to inhibit sleep when printing'
'python2-psutil: to increase process priority when printing')
makedepends=('cython2')