summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Price2015-08-03 19:41:52 +0100
committerWill Price2015-08-03 19:41:52 +0100
commitcbda6ea42cae45265022e8b60fa178da5fbd28e4 (patch)
treeb98111c846202976dc89082f24fc7551b1c06db7
downloadaur-probe.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4bf0e2a6e51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = probe
+ pkgdesc = ProBE is an animator for CSP processes allowing the user to explore the behaviour of models interactively
+ pkgver = 1.30
+ pkgrel = 1
+ url = http://www.fsel.com/probe_download.html
+ arch = x86_64
+ arch = i686
+ license = Custom
+ source = http://www.fsel.com/download/probe-1.30-linux6.tar.gz
+ md5sums = 8c1809f326ea0cf8013d0e4b24c7e6ac
+
+pkgname = probe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e06d7f2355f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Will Price <will.price94+aur@gmail.com>
+pkgname=probe
+pkgver=1.30
+pkgrel=1
+epoch=
+pkgdesc="ProBE is an animator for CSP processes allowing the user to
+explore the behaviour of models interactively"
+arch=('x86_64' 'i686')
+url="http://www.fsel.com/probe_download.html"
+license=('Custom')
+groups=()
+if [ $CARCH = 'x86_64' ]; then
+ depends=('lib32-libxext')
+else
+ depends=()
+fi
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('http://www.fsel.com/download/probe-1.30-linux6.tar.gz')
+noextract=()
+md5sums=('8c1809f326ea0cf8013d0e4b24c7e6ac')
+
+package() {
+ mkdir -p "$pkgdir"/usr/{share/{doc/probe,probe},bin}
+
+ cd "$srcdir/$pkgname-$pkgver-linux6"
+ install -m 755 probe "$pkgdir/usr/share/probe/"
+ install -m 755 README "$pkgdir/usr/share/doc/probe/"
+ install -m 755 -T Licence "$pkgdir/usr/share/doc/probe/LICENSE"
+ ln -s /usr/share/probe/probe "$pkgdir/usr/bin"
+}