summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Brandwein2018-11-19 04:14:03 -0300
committerEric Brandwein2018-11-19 04:14:03 -0300
commit10f0aecf512298283b69fb5bf1d659c32921b661 (patch)
treef3698bb16ca79181192a9bb2b54094ccf32beea0
downloadaur-process-watcher-git.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62099f1adf4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = process-watcher-git
+ pkgdesc = Watch Linux processes and notify when they complete.
+ pkgver = r25.5d2037d
+ pkgrel = 1
+ url = https://github.com/arlowhite/process-watcher
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-dbus
+ optdepends = python-notify2: desktop notifications support
+ source = git+https://github.com/arlowhite/process-watcher.git
+ md5sums = SKIP
+
+pkgname = process-watcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..766282ead422
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Eric Brandwein <brandweineric at gmail dot com>
+pkgname=process-watcher-git
+pkgver=r25.5d2037d
+pkgrel=1
+pkgdesc="Watch Linux processes and notify when they complete."
+arch=(any)
+url="https://github.com/arlowhite/process-watcher"
+license=('MIT')
+groups=()
+depends=('python' 'python-dbus')
+makedepends=('git')
+optdepends=('python-notify2: desktop notifications support')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/arlowhite/process-watcher.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s\n" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ # There's probably a better installation directory than
+ # /opt, and probably a better way of copying all files;
+ # if someone knows and wants to help, email me.
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ mkdir $pkgdir/opt/
+ cp -r $srcdir/${pkgname%-git}/ "$pkgdir/opt/${pkgname%-git}"
+ mkdir $pkgdir/usr/bin
+ ln -s $pkgdir/opt/${pkgname%-git}/process_watcher.py $pkgdir/usr/bin/process_watcher
+ chmod +x $pkgdir/usr/bin/process_watcher
+}