summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Araujo2020-05-29 00:23:02 +0100
committerDaniel Araujo2020-05-29 00:23:02 +0100
commitb77d2f04c855f115b676964a4fd5a3e0e465945b (patch)
tree19ba3d8a05a76ab639ad3a1b493c64515cc03918
downloadaur-proctal-git.tar.gz
Bringing proctal to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2fb06c912e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = proctal-git
+ pkgdesc = A tool for modding programs on Linux at runtime.
+ pkgver = r493.2b794f1
+ pkgrel = 1
+ url = https://github.com/daniel-araujo/proctal
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = autoconf
+ makedepends = php
+ optdepends = keystone: to compile assembly language
+ optdepends = capstone: to decompile bytecode into assembly
+ source = git+https://github.com/daniel-araujo/proctal.git
+ md5sums = SKIP
+
+pkgname = proctal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0b198456d12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daniel Araujo <contact@daniel-araujo.pt>
+pkgname='proctal-git'
+pkgver=r493.2b794f1
+pkgrel=1
+pkgdesc='A tool for modding programs on Linux at runtime.'
+url='https://github.com/daniel-araujo/proctal'
+arch=('x86_64' 'aarch64')
+license=('GPL3')
+optdepends=(
+ 'keystone: to compile assembly language'
+ 'capstone: to decompile bytecode into assembly')
+makedepends=('git' 'autoconf' 'php')
+source=("git+https://github.com/daniel-araujo/proctal.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd proctal
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd proctal
+
+ git clone https://github.com/hroptatyr/yuck.git
+ cd yuck
+ git reset --hard 958e4cf76a305939b73c15a806cedac8a221933a
+ autoreconf -fi
+ ./configure
+ make
+ cd ..
+
+ ./bootstrap
+ ./configure --with-yuck="$PWD/yuck/src/yuck" --prefix=/usr
+ make
+}
+
+package() {
+ cd proctal
+ make DESTDIR="$pkgdir/" install
+}