summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortest4822024-02-21 01:50:44 +0800
committertest4822024-02-21 01:50:44 +0800
commit566fbc0f8e7e3b69ee027824c46e04059006a750 (patch)
treece3cd8cc31012928d7ebd92bb9eb669e8839e0e6
downloadaur-profile-sync-daemon-edge-stable.tar.gz
Init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD19
-rw-r--r--microsoft-edge2
4 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea8c77060f80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = profile-sync-daemon-edge-stable
+ pkgdesc = Microsoft Edge Stable support for profile-sync-daemon
+ pkgver = 2024.02.21
+ pkgrel = 1
+ url = https://github.com/graysky2/profile-sync-daemon/issues/279
+ arch = any
+ license = unlicense
+ depends = profile-sync-daemon
+ optdepends = microsoft-edge-stable-bin: the target browser
+ source = microsoft-edge
+ md5sums = 19f1f55d59e55334b9c61f12b94f35ee
+
+pkgname = profile-sync-daemon-edge-stable
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0effd571ed95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae94f6c1136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Eliot_Alderson <eliotjoking at gmail dot com>
+
+pkgname=profile-sync-daemon-edge-stable
+pkgver=2024.02.21
+pkgrel=1
+pkgdesc="Microsoft Edge Stable support for profile-sync-daemon"
+url="https://github.com/graysky2/profile-sync-daemon/issues/279"
+arch=('any')
+license=('unlicense')
+depends=('profile-sync-daemon')
+optdepends=(
+ 'microsoft-edge-stable-bin: the target browser'
+)
+source=("microsoft-edge")
+md5sums=('19f1f55d59e55334b9c61f12b94f35ee')
+
+package() {
+ install -Dm644 microsoft-edge "${pkgdir}/usr/share/psd/browsers/microsoft-edge"
+}
diff --git a/microsoft-edge b/microsoft-edge
new file mode 100644
index 000000000000..f4ef79ac4dd7
--- /dev/null
+++ b/microsoft-edge
@@ -0,0 +1,2 @@
+DIRArr[0]="$XDG_CONFIG_HOME/$browser"
+PSNAME="msedge"