summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2015-07-02 16:54:53 +0200
committerMiguel Revilla2015-07-02 16:54:53 +0200
commit2c7535c33dbe5e01fd8b57c6a3b218ab36b7dace (patch)
tree597c40d0f0f39899211309246490de13adb45f05
downloadaur-2c7535c33dbe5e01fd8b57c6a3b218ab36b7dace.tar.gz
Initial import
-rw-r--r--.AURINFO23
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD62
-rw-r--r--proftpd.install3
-rw-r--r--proftpd.logrotate5
-rw-r--r--proftpd.service12
-rw-r--r--proftpd.tmpfiles1
7 files changed, 133 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7ede59e4cf90
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,23 @@
+pkgbase = proftpd
+ pkgdesc = High-performance, scalable FTP server
+ pkgver = 1.3.5
+ pkgrel = 2
+ epoch = 1
+ url = http://www.proftpd.org/
+ install = proftpd.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = libmariadbclient
+ depends = postgresql-libs
+ depends = libcap
+ depends = pam
+ source = ftp://ftp.proftpd.org/distrib/source/proftpd-1.3.5.tar.gz
+ source = proftpd.logrotate
+ source = proftpd.service
+ source = proftpd.tmpfiles
+ options = !emptydirs
+ backup = etc/proftpd.conf
+
+pkgname = proftpd
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39dc33dae121
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = proftpd
+ pkgdesc = High-performance, scalable FTP server
+ pkgver = 1.3.5
+ pkgrel = 2
+ epoch = 1
+ url = http://www.proftpd.org/
+ install = proftpd.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = libmariadbclient
+ depends = postgresql-libs
+ depends = libcap
+ depends = pam
+ options = !emptydirs
+ backup = etc/proftpd.conf
+ source = ftp://ftp.proftpd.org/distrib/source/proftpd-1.3.5.tar.gz
+ source = proftpd.logrotate
+ source = proftpd.service
+ source = proftpd.tmpfiles
+ md5sums = aff1bff40e675244d72c4667f203e5bb
+ md5sums = 4d7a3eedc1852d4fa9faafc072fb8320
+ md5sums = f7e0c3a402a845ba8d546b2801f77ed2
+ md5sums = 907b149a120b046f05647c73502e23c9
+
+pkgname = proftpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e489e7b95cd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=proftpd
+pkgver=1.3.5
+pkgrel=2
+epoch=1
+pkgdesc='High-performance, scalable FTP server'
+arch=('x86_64' 'i686')
+url='http://www.proftpd.org/'
+license=('GPL')
+depends=('libmariadbclient' 'postgresql-libs' 'libcap' 'pam')
+backup=('etc/proftpd.conf')
+options=('!emptydirs')
+install=${pkgname}.install
+source=("ftp://ftp.proftpd.org/distrib/source/${pkgname}-${pkgver}.tar.gz"
+ 'proftpd.logrotate' 'proftpd.service'
+ 'proftpd.tmpfiles')
+md5sums=('aff1bff40e675244d72c4667f203e5bb'
+ '4d7a3eedc1852d4fa9faafc072fb8320'
+ 'f7e0c3a402a845ba8d546b2801f77ed2'
+ '907b149a120b046f05647c73502e23c9')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --disable-pam \
+ --with-modules=mod_quotatab:mod_quotatab_sql:mod_quotatab_file:mod_tls:mod_ldap:mod_sql:mod_sql_mysql:mod_sql_postgres \
+ --sysconfdir=/etc \
+ --localstatedir=/run/proftpd \
+ --enable-ctrls \
+ --enable-ipv6 \
+ --with-includes=/usr/include/mysql:/usr/include/postgresql \
+ --with-libraries=/usr/lib/mysql:/usr/lib/postgresql \
+ --enable-nls \
+ --with-systemd
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ sed -i 's|nogroup|nobody|g' "${pkgdir}/etc/proftpd.conf"
+
+ install -Dm644 ../proftpd.logrotate "${pkgdir}/etc/logrotate.d/proftpd"
+ install -Dm755 contrib/xferstats.holger-preiss "${pkgdir}/usr/bin/ftpstats"
+
+ install -d "${pkgdir}/usr/lib/systemd/system/"
+ install -m644 "${srcdir}"/proftpd.service "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm644 "${srcdir}"/proftpd.tmpfiles \
+ "${pkgdir}"/usr/lib/tmpfiles.d/proftpd.conf
+
+ # /run is tmpfs
+ rmdir "${pkgdir}"/run/{proftpd,}
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/proftpd.install b/proftpd.install
new file mode 100644
index 000000000000..6d9888496216
--- /dev/null
+++ b/proftpd.install
@@ -0,0 +1,3 @@
+post_install() {
+ systemd-tmpfiles --create proftpd.conf
+}
diff --git a/proftpd.logrotate b/proftpd.logrotate
new file mode 100644
index 000000000000..e7c36dadbc85
--- /dev/null
+++ b/proftpd.logrotate
@@ -0,0 +1,5 @@
+/var/log/xferlog {
+ postrotate
+ /bin/kill -HUP `cat /var/run/proftpd/proftpd.pid 2>/dev/null` 2>/dev/null || true
+ endscript
+}
diff --git a/proftpd.service b/proftpd.service
new file mode 100644
index 000000000000..60d987fa0a9b
--- /dev/null
+++ b/proftpd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=ProFTPD FTP Server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/proftpd/proftpd.pid
+ExecStart=/usr/bin/proftpd
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy = multi-user.target
diff --git a/proftpd.tmpfiles b/proftpd.tmpfiles
new file mode 100644
index 000000000000..241dc7cb1bdc
--- /dev/null
+++ b/proftpd.tmpfiles
@@ -0,0 +1 @@
+d /run/proftpd 0755 root root