summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2023-06-19 19:51:13 +0200
committerBlair Bonnett2023-06-19 19:51:13 +0200
commita504d2dfc3f0f486b8c560639a921d4c6ae9e338 (patch)
tree62636a132d973bb3d729d752a2bd1866a239e119
parent649540f6bbef031cbbf9fea8d3afcf8ea2add68f (diff)
downloadaur-proj6.tar.gz
Add cstdint header to fix compilation error.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--add_cstdint_header.patch9
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d96f876b8848..44cdd93f59f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proj6
pkgdesc = Cartographic Projections library (version 6)
pkgver = 6.3.2
- pkgrel = 2
+ pkgrel = 3
url = https://trac.osgeo.org/proj/
arch = x86_64
license = MIT
@@ -13,10 +13,11 @@ pkgbase = proj6
source = https://download.osgeo.org/proj/proj-datumgrid-1.8.zip
source = gie_self_test.patch
source = add_suffix.patch
+ source = add_cstdint_header.patch
sha256sums = cb776a70f40c35579ae4ba04fb4a388c1d1ce025a1df6171350dc19f25b80311
sha256sums = b9838ae7e5f27ee732fb0bfed618f85b36e8bb56d7afb287d506338e9f33861e
sha256sums = a0ec0f1fd7c91972d005f60685f68c573c9742a6c030670e17b8989be109c3e5
sha256sums = ff22b6684c72e0a24d6b214487f09d74c80b1d0520d90297afbac5ce9163e59f
+ sha256sums = 30843e472d87a6085d8f3d230458957f427a1bb812ca08ab192c35cc51cd2a7c
pkgname = proj6
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c99425d3d38..d86cbf3a136e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=proj6
_pkgname=proj
pkgver=6.3.2
-pkgrel=2
+pkgrel=3
pkgdesc='Cartographic Projections library (version 6)'
arch=('x86_64')
url="https://trac.osgeo.org/proj/"
@@ -17,16 +17,19 @@ makedepends=('cmake' 'gmock' 'gtest')
source=(https://github.com/OSGeo/PROJ/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz
https://download.osgeo.org/proj/proj-datumgrid-1.8.zip
gie_self_test.patch
- add_suffix.patch)
+ add_suffix.patch
+ add_cstdint_header.patch)
sha256sums=('cb776a70f40c35579ae4ba04fb4a388c1d1ce025a1df6171350dc19f25b80311'
'b9838ae7e5f27ee732fb0bfed618f85b36e8bb56d7afb287d506338e9f33861e'
'a0ec0f1fd7c91972d005f60685f68c573c9742a6c030670e17b8989be109c3e5'
- 'ff22b6684c72e0a24d6b214487f09d74c80b1d0520d90297afbac5ce9163e59f')
+ 'ff22b6684c72e0a24d6b214487f09d74c80b1d0520d90297afbac5ce9163e59f'
+ '30843e472d87a6085d8f3d230458957f427a1bb812ca08ab192c35cc51cd2a7c')
prepare() {
cd "${srcdir}"/$_pkgname-$pkgver
patch -p1 -i "${srcdir}"/gie_self_test.patch
patch -p0 -i "${srcdir}"/add_suffix.patch
+ patch -p0 -i "${srcdir}"/add_cstdint_header.patch
}
build(){
diff --git a/add_cstdint_header.patch b/add_cstdint_header.patch
new file mode 100644
index 000000000000..e0535791040d
--- /dev/null
+++ b/add_cstdint_header.patch
@@ -0,0 +1,9 @@
+--- src/proj_json_streaming_writer.hpp
++++ src/proj_json_streaming_writer.hpp
+@@ -33,6 +33,7 @@ Thanks to AUR user lsr for the patch
+
+ #include <vector>
+ #include <string>
++#include <cstdint>
+
+ #define CPL_DLL