summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Fisher2018-10-13 16:19:32 -0700
committerKevin Fisher2018-10-13 16:19:32 -0700
commit182ff5e99489459e858772f0c51068fa70e7c658 (patch)
treef7272d1beaad08ee639a65d89f6914387b7b04ba
downloadaur-pros-core-bin.tar.gz
Creation of PKGBUILD and .SRCINFO for pros-core-bin
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..642eb9e66735
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pros-core-bin
+ pkgdesc = PROS core components, including the CLI and Arm Toolchain.
+ pkgver = 2.6.1.0
+ pkgrel = 1
+ url = https://github.com/purduesigbots/pros
+ arch = x86_64
+ license = MPL2
+ depends = arm-none-eabi-gcc
+ depends = arm-none-eabi-newlib
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/purduesigbots/pros/releases/download/2.12.2/pros-core-2.6.1-amd64.deb
+ sha512sums_x86_64 = e8a27efe01be0224872c0a83ed74289e527ee0a907c887ca6e304478b33195f21c951e04cc55e36316ff2271a7473adfc40b6265efe99d23e8e4373bd0d2bd8f
+
+pkgname = pros-core-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f53251530454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: kfish610 <kfish610@gmail.com>
+pkgname=pros-core-bin
+pkgver=2.6.1.0
+pkgrel=1
+pkgdesc="PROS core components, including the CLI and Arm Toolchain."
+arch=('x86_64')
+url="https://github.com/purduesigbots/pros"
+license=('MPL2')
+depends=('arm-none-eabi-gcc' 'arm-none-eabi-newlib')
+options=('!strip' '!emptydirs')
+source_x86_64=("https://github.com/purduesigbots/pros/releases/download/2.12.2/pros-core-2.6.1-amd64.deb")
+sha512sums_x86_64=('e8a27efe01be0224872c0a83ed74289e527ee0a907c887ca6e304478b33195f21c951e04cc55e36316ff2271a7473adfc40b6265efe99d23e8e4373bd0d2bd8f')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}