summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-08-30 16:13:00 +0300
committerStelios Tsampas2023-08-30 16:13:00 +0300
commit6392cd8958ca3fb9fc03bffaa62f32f95d7b5781 (patch)
tree5b0fde472ce01af942f2bfe945293b374073db83
parent271c7201ceb610d8fab5d764275bde177032b7da (diff)
downloadaur-6392cd8958ca3fb9fc03bffaa62f32f95d7b5781.tar.gz
[proton] Fix gst-plugins-rs failure due to llvm 16
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
-rw-r--r--PKGBUILD.testing11
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571ca51bf90d..268d90e980e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components
pkgver = 8.0.3.3
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://github.com/ValveSoftware/Proton
install = proton.install
@@ -159,6 +159,7 @@ pkgbase = proton
noextract = wine-mono-7.4.1-x86.tar.xz
options = !staticlibs
options = !lto
+ options = !debug
options = emptydirs
source = proton::git+https://github.com/ValveSoftware/Proton.git#tag=proton-8.0-3c
source = https://dl.winehq.org/wine/wine-gecko/2.47.3/wine-gecko-2.47.3-x86.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index b966f9eec17c..fa55bc1c6315 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@ _commit=
pkgver=8.0.3.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
arch=(x86_64 x86_64_v3)
-options=(!staticlibs !lto emptydirs)
+options=(!staticlibs !lto !debug emptydirs)
license=('custom')
depends=(
@@ -144,19 +144,24 @@ prepare() {
# Explicitly set origin URL for submodules using relative paths
git remote set-url origin https://github.com/ValveSoftware/Proton.git
- git -c protocol.file.allow=always submodule update --init --filter=tree:0 --recursive
+ git submodule update --init --filter=tree:0 --recursive
+
+ # Fix bindgen issue with llvm 16 by updating dav1d to something newer
+ sed 's/dav1d = "0.7"/dav1d = "0.9"/g' -i gst-plugins-rs/video/dav1d/Cargo.toml
+ pushd dav1d; git checkout 1.2.1; popd
for rustlib in gst-plugins-rs media-converter; do
pushd $rustlib
export RUSTUP_TOOLCHAIN=stable
export CARGO_HOME="${SRCDEST}"/proton-cargo
+ cargo update
cargo fetch --locked --target "i686-unknown-linux-gnu"
cargo fetch --locked --target "x86_64-unknown-linux-gnu"
popd
done
patch -p1 -i "$srcdir"/0001-AUR-Pkgbuild-changes.patch
- patch -p1 -i "$srcdir"/0002-AUR-Do-not-update-cargo-crates.patch
+ #patch -p1 -i "$srcdir"/0002-AUR-Do-not-update-cargo-crates.patch
patch -p1 -i "$srcdir"/0003-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch
patch -p1 -i "$srcdir"/0004-AUR-Strip-binaries-early.patch
patch -p1 -i "$srcdir"/fix_hwnd_changes_meaning.patch
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 9691c63ec3ce..a04f68785570 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,12 +6,12 @@ _commit=
pkgver=8.0.3.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
arch=(x86_64 x86_64_v3)
-options=(!staticlibs !lto emptydirs)
+options=(!staticlibs !lto !debug emptydirs)
license=('custom')
depends=(
@@ -144,12 +144,17 @@ prepare() {
# Explicitly set origin URL for submodules using relative paths
git remote set-url origin https://github.com/ValveSoftware/Proton.git
- git -c protocol.file.allow=always submodule update --init --filter=tree:0 --recursive
+ git submodule update --init --filter=tree:0 --recursive
+
+ # Fix bindgen issue with llvm 16 by updating dav1d to something newer
+ sed 's/dav1d = "0.7"/dav1d = "0.9"/g' -i gst-plugins-rs/video/dav1d/Cargo.toml
+ pushd dav1d; git checkout 1.2.1; popd
for rustlib in gst-plugins-rs media-converter; do
pushd $rustlib
export RUSTUP_TOOLCHAIN=stable
export CARGO_HOME="${SRCDEST}"/proton-cargo
+ cargo update
cargo fetch --locked --target "i686-unknown-linux-gnu"
cargo fetch --locked --target "x86_64-unknown-linux-gnu"
popd