summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-05-05 16:25:12 +0300
committerStelios Tsampas2023-05-06 02:43:37 +0300
commit6992d6f8a591bf3d143d5a7997753674bbc7e16a (patch)
treea3e0943fb8e9b6c635d446fe968a8fc02e6c2ff8
parentc08baa83f075dd68fa0ff3e1f57253f7fb71652f (diff)
downloadaur-6992d6f8a591bf3d143d5a7997753674bbc7e16a.tar.gz
[proton] Fix steam_helper compilation on GCC 13
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.testing6
-rw-r--r--fix_hwnd_changes_meaning.patch25
4 files changed, 38 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2ed23372d8e..d2a5a7b33abf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components
pkgver = 8.0.2.3
- pkgrel = 3
+ pkgrel = 6
epoch = 1
url = https://github.com/ValveSoftware/Proton
install = proton.install
@@ -190,6 +190,7 @@ pkgbase = proton
source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.4.1/wine-mono-7.4.1-x86.tar.xz
source = 0001-AUR-Pkgbuild-changes.patch
source = 0002-AUR-Do-not-update-cargo-crates.patch
+ source = fix_hwnd_changes_meaning.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -219,5 +220,6 @@ pkgbase = proton
sha256sums = 1286afc67b0a329f5e2d98d9e803ca5906a841ad5486e9b3b1fefa1124b15622
sha256sums = edbbcc93ef53a81150baa409b9c55e756edef6dcda4dd0b79f8fdcaae743aac9
sha256sums = 9c107461440cb8cd7d54f994b235dc0be6a11370e0a60578523633c07024c976
+ sha256sums = 20824bb565fefcad4aa978c54e0f8b9d9d17b7b52fb03fc87943150de148f06f
pkgname = proton
diff --git a/PKGBUILD b/PKGBUILD
index 5ce29aec9a4f..469293039ff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=8.0.2.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=3
+pkgrel=6
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -112,6 +112,7 @@ source=(
)
# Optional patches
source+=(
+ fix_hwnd_changes_meaning.patch
)
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
@@ -235,6 +236,8 @@ prepare() {
patch -p1 -i "$srcdir"/0001-AUR-Pkgbuild-changes.patch
patch -p1 -i "$srcdir"/0002-AUR-Do-not-update-cargo-crates.patch
+ patch -p1 -i "$srcdir"/fix_hwnd_changes_meaning.patch
+
# Remove repos from srcdir to save space
for submodule in "${_submodules[@]}"; do
rm -rf "$srcdir"/"${submodule%::*}"
@@ -353,5 +356,6 @@ sha256sums=('SKIP'
'9c107461440cb8cd7d54f994b235dc0be6a11370e0a60578523633c07024c976')
# Optional patches
sha256sums+=(
+ '20824bb565fefcad4aa978c54e0f8b9d9d17b7b52fb03fc87943150de148f06f'
)
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 9881a0e2721e..fcc61b046911 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=
pkgver=8.0.2.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=3
+pkgrel=6
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -112,6 +112,7 @@ source=(
)
# Optional patches
source+=(
+ fix_hwnd_changes_meaning.patch
)
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
@@ -235,6 +236,8 @@ prepare() {
patch -p1 -i "$srcdir"/0001-AUR-Pkgbuild-changes.patch
patch -p1 -i "$srcdir"/0002-AUR-Do-not-update-cargo-crates.patch
+ patch -p1 -i "$srcdir"/fix_hwnd_changes_meaning.patch
+
# Remove repos from srcdir to save space
for submodule in "${_submodules[@]}"; do
rm -rf "$srcdir"/"${submodule%::*}"
@@ -356,5 +359,6 @@ sha256sums=('SKIP'
'SKIP')
# Optional patches
sha256sums+=(
+ '20824bb565fefcad4aa978c54e0f8b9d9d17b7b52fb03fc87943150de148f06f'
)
diff --git a/fix_hwnd_changes_meaning.patch b/fix_hwnd_changes_meaning.patch
new file mode 100644
index 000000000000..87b19a458885
--- /dev/null
+++ b/fix_hwnd_changes_meaning.patch
@@ -0,0 +1,25 @@
+diff --git a/steam_helper/steam.cpp b/steam_helper/steam.cpp
+index 190a8c05..afe7916b 100644
+--- a/steam_helper/steam.cpp
++++ b/steam_helper/steam.cpp
+@@ -34,7 +34,9 @@
+
+ #include "ntstatus.h"
+ #define WIN32_NO_STATUS
++extern "C" {
+ #include <windows.h>
++}
+ #include <winternl.h>
+ #include <shlobj.h>
+ #include <string.h>
+diff --git a/vrclient_x64/vrclient_x64/json_converter.cpp b/vrclient_x64/vrclient_x64/json_converter.cpp
+index 83fd2ec0..64d209a2 100644
+--- a/vrclient_x64/vrclient_x64/json_converter.cpp
++++ b/vrclient_x64/vrclient_x64/json_converter.cpp
+@@ -1,4 +1,6 @@
++extern "C" {
+ #include <windows.h>
++}
+ #include <wine/debug.h>
+
+ WINE_DEFAULT_DEBUG_CHANNEL(vrclient);