summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2018-08-26 14:38:10 -0400
committerSean Anderson2018-08-26 14:38:10 -0400
commit7409242ad77839b936d23873cbdc4e9b455e6322 (patch)
treeb49d351bfc9be9847f1cbdf2b8824bfcc78b50e7
parent17046c61fe41a0ae73ed47151a1619d5bc2e24fe (diff)
downloadaur-7409242ad77839b936d23873cbdc4e9b455e6322.tar.gz
Add a separate _pkgver variable for upstream version
This will help when valve randomly decides to use slightly different version formats.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95ed5970b062..4427dea737e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = proton
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components
- pkgver = 3.7_20180823
+ pkgver = 3.7_20180824_beta
pkgrel = 1
url = https://github.com/ValveSoftware/Proton/
arch = x86_64
license = BSD
depends = python2
depends = wine
- source = https://github.com/ValveSoftware/Proton/archive/proton-3.7-20180823.tar.gz
- md5sums = 3d44538bf4ee0547de219a793c92194f
+ source = https://github.com/ValveSoftware/Proton/archive/proton-3.7beta-20180824.tar.gz
+ md5sums = 1ee5c8c0f53bb5cf9d0d2375940a9f59
pkgname = proton
diff --git a/PKGBUILD b/PKGBUILD
index 9b1cbf50807f..dee8f8d9f096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,10 @@
# Mantainer: Sean Anderson <seanga2@gamil.com>
pkgname=proton
-pkgver=3.7_20180823
+# Upstream version
+_pkgver='3.7beta-20180824'
+# Version for arch
+#pkgver="${_pkgver//_/-}"
+pkgver=3.7_20180824_beta
pkgrel=1
epoch=
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
@@ -25,17 +29,17 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/ValveSoftware/Proton/archive/$pkgname-${pkgver//_/-}.tar.gz")
+source=("https://github.com/ValveSoftware/Proton/archive/$pkgname-$_pkgver.tar.gz")
noextract=()
-md5sums=('3d44538bf4ee0547de219a793c92194f')
+md5sums=('1ee5c8c0f53bb5cf9d0d2375940a9f59')
prepare() {
- cd "Proton-$pkgname-${pkgver//_/-}"
+ cd "Proton-$pkgname-$_pkgver"
sed -i 's/openvr_v0.9.16//g' vrclient_x64/vrclient_x64/*
}
build() {
- cd "Proton-$pkgname-${pkgver//_/-}"
+ cd "Proton-$pkgname-$_pkgver"
export CXXFLAGS="$CXXFLAGS -Wno-attributes"
export WINEMAKEFLAGS="--nosource-fix --nolower-include --nodlls --nomsvcrt --dll"
@@ -67,11 +71,11 @@ build() {
}
check() {
- cd "Proton-$pkgname-${pkgver//_/-}"
+ cd "Proton-$pkgname-$_pkgver"
}
package() {
- cd "Proton-$pkgname-${pkgver//_/-}"
+ cd "Proton-$pkgname-$_pkgver"
install -d -m755 $pkgdir/usr/share/licenses/$pkgname
install -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE