summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-26 18:30:15 +0200
committerStelios Tsampas2024-01-26 18:30:15 +0200
commit77cedc4024fe46830ec0fd445317ec0fcb1a8738 (patch)
tree77ee989f5e1bb581cd2f6ab2853459100fc16d29
parent28e810f962013b509134668686c24c0081357464 (diff)
downloadaur-77cedc4024fe46830ec0fd445317ec0fcb1a8738.tar.gz
[proton] Update and re-enable march and mtune, disable AVX for x64 too
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94dece92561d..1c23347a376a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components
pkgver = 8.0.5.3
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://github.com/ValveSoftware/Proton
install = proton.install
diff --git a/PKGBUILD b/PKGBUILD
index 895cdf3dd514..27599bdbed9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=8.0.5.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.1.0
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -170,9 +170,9 @@ build() {
--proton-sdk-image="" \
--build-name="${pkgname}"
-# local -a split=($CFLAGS)
-# local -A flags
-# for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
+ local -a split=($CFLAGS)
+ local -A flags
+ for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
@@ -192,8 +192,8 @@ build() {
# https://bugs.winehq.org/show_bug.cgi?id=43516
# AVX is "hard" disabled for 32bit in any case.
# AVX2 for both 32bit and 64bit is disabled below.
- CFLAGS+=" -mno-avx2"
- CXXFLAGS+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2 -mno-avx"
+ CXXFLAGS+=" -mno-avx2 -mno-avx"
export CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS