summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-07-12 16:35:21 +0300
committerStelios Tsampas2023-07-12 16:35:21 +0300
commit7fbc1beae6a2eaf27f694787a7fdf37e590c0d94 (patch)
tree66e07ab1ca7b69746dbc8c797e07ef0095083f1f
parentac1c41a54b38d45687111b33775b775336c4609b (diff)
downloadaur-7fbc1beae6a2eaf27f694787a7fdf37e590c0d94.tar.gz
[proton] Fix dll copy location
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.testing6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1741b92e98b..ec070a674203 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components
pkgver = 8.0.2.3
- pkgrel = 7
+ pkgrel = 8
epoch = 1
url = https://github.com/ValveSoftware/Proton
install = proton.install
diff --git a/PKGBUILD b/PKGBUILD
index b22eb3b76939..b24937b74ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=8.0.2.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=7
+pkgrel=8
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -308,9 +308,9 @@ package() {
# by the patched proton script. Bundling the helps to avoid making mingw-w64-gcc package
# a runtime dependency.
cp /usr/i686-w64-mingw32/bin/{libgcc_s_dw2-1.dll,libwinpthread-1.dll} \
- "$_compatdir/${pkgname}"/files/lib/vkd3d/
+ "$_compatdir/${pkgname}"/dist/lib/vkd3d/
cp /usr/x86_64-w64-mingw32/bin/{libgcc_s_seh-1.dll,libwinpthread-1.dll} \
- "$_compatdir/${pkgname}"/files/lib64/vkd3d/
+ "$_compatdir/${pkgname}"/dist/lib64/vkd3d/
mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
mv "$_compatdir/${pkgname}"/LICENSE{,.OFL} \
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index c75f1c2ef6bd..be3bbfc1001b 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=
pkgver=8.0.2.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=7
+pkgrel=8
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -308,9 +308,9 @@ package() {
# by the patched proton script. Bundling the helps to avoid making mingw-w64-gcc package
# a runtime dependency.
cp /usr/i686-w64-mingw32/bin/{libgcc_s_dw2-1.dll,libwinpthread-1.dll} \
- "$_compatdir/${pkgname}"/files/lib/vkd3d/
+ "$_compatdir/${pkgname}"/dist/lib/vkd3d/
cp /usr/x86_64-w64-mingw32/bin/{libgcc_s_seh-1.dll,libwinpthread-1.dll} \
- "$_compatdir/${pkgname}"/files/lib64/vkd3d/
+ "$_compatdir/${pkgname}"/dist/lib64/vkd3d/
mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
mv "$_compatdir/${pkgname}"/LICENSE{,.OFL} \