summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-12-04 18:56:39 +0200
committerStelios Tsampas2022-12-04 18:56:39 +0200
commit911d50410d663e76e1a64c2d6edeeca83e24607d (patch)
tree3f075d03f9f596fd177296739f35acb0c0ab9ff9
parent32cf6c7791f2c1b672797b5ac8af95651bc8346a (diff)
downloadaur-911d50410d663e76e1a64c2d6edeeca83e24607d.tar.gz
[proton] add missing submodules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.testing6
3 files changed, 16 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 414ddc0ff225..e66783090709 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -223,11 +223,13 @@ pkgbase = proton
source = Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = SPIRV-Headers::git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
+ source = glslang::git+https://github.com/KhronosGroup/glslang.git
source = gst-libav::git+https://gitlab.freedesktop.org/gstreamer/gst-libav.git
source = ffmpeg::git+https://git.ffmpeg.org/ffmpeg.git
source = dav1d::git+https://code.videolan.org/videolan/dav1d.git
source = gst-plugins-rs::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs.git
source = dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
+ source = graphene::git+https://github.com/ebassi/graphene.git
source = https://dl.winehq.org/wine/wine-gecko/2.47.3/wine-gecko-2.47.3-x86.tar.xz
source = https://dl.winehq.org/wine/wine-gecko/2.47.3/wine-gecko-2.47.3-x86_64.tar.xz
source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.3.0/wine-mono-7.3.0-x86.tar.xz
@@ -254,6 +256,8 @@ pkgbase = proton
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 08d318f3dd6440a8a777cf044ccab039b0d9c8809991d2180eb3c9f903135db3
sha256sums = 0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75
sha256sums = 60314f255031b2f4dc49f22eacfcd2b3b8b2b491120d703b4b62cc1fef0f9bdd
diff --git a/PKGBUILD b/PKGBUILD
index d8680bd9f48a..57fc74f72313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -117,11 +117,13 @@ source=(
Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
SPIRV-Headers::git+https://github.com/KhronosGroup/SPIRV-Headers.git
Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
+ glslang::git+https://github.com/KhronosGroup/glslang.git
gst-libav::git+https://gitlab.freedesktop.org/gstreamer/gst-libav.git
ffmpeg::git+https://git.ffmpeg.org/ffmpeg.git
dav1d::git+https://code.videolan.org/videolan/dav1d.git
gst-plugins-rs::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs.git
dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
+ graphene::git+https://github.com/ebassi/graphene.git
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
0001-wldap32-25946b48148784e8275c1685f6498ab88f553ca3.patch
@@ -194,10 +196,12 @@ prepare() {
Vulkan-Headers
SPIRV-Headers
Vulkan-Loader
+ glslang
gst-libav
ffmpeg
dav1d
gst-plugins-rs
+ graphene
)
for submodule in "${_submodules[@]}"; do
@@ -356,6 +360,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'08d318f3dd6440a8a777cf044ccab039b0d9c8809991d2180eb3c9f903135db3'
'0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75'
'60314f255031b2f4dc49f22eacfcd2b3b8b2b491120d703b4b62cc1fef0f9bdd'
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index cb16c7cfad3b..41282a28438f 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -117,11 +117,13 @@ source=(
Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
SPIRV-Headers::git+https://github.com/KhronosGroup/SPIRV-Headers.git
Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
+ glslang::git+https://github.com/KhronosGroup/glslang.git
gst-libav::git+https://gitlab.freedesktop.org/gstreamer/gst-libav.git
ffmpeg::git+https://git.ffmpeg.org/ffmpeg.git
dav1d::git+https://code.videolan.org/videolan/dav1d.git
gst-plugins-rs::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs.git
dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
+ graphene::git+https://github.com/ebassi/graphene.git
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
0001-wldap32-25946b48148784e8275c1685f6498ab88f553ca3.patch
@@ -197,10 +199,12 @@ prepare() {
Vulkan-Headers
SPIRV-Headers
Vulkan-Loader
+ glslang
gst-libav
ffmpeg
dav1d
gst-plugins-rs
+ graphene
)
for submodule in "${_submodules[@]}"; do
@@ -362,6 +366,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'08d318f3dd6440a8a777cf044ccab039b0d9c8809991d2180eb3c9f903135db3'
'0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75'
'60314f255031b2f4dc49f22eacfcd2b3b8b2b491120d703b4b62cc1fef0f9bdd'