summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-03-24 19:25:24 +0200
committerStelios Tsampas2023-03-24 19:25:24 +0200
commite11a9de11515050aff7a2a472890462fde9c9b72 (patch)
tree4f0af1a00c814424f17a4215388f04fb2a315978
parentb4f622684a49dc0137c4013d80c2248b6d56720d (diff)
downloadaur-e11a9de11515050aff7a2a472890462fde9c9b72.tar.gz
[meta] switch to -O2
-rw-r--r--PKGBUILD.testing4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 76e7359c123d..015e98ba2d19 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -269,8 +269,8 @@ build() {
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
- export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -ftree-vectorize -fno-semantic-interposition"
- export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -ftree-vectorize -fno-semantic-interposition"
+ export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
+ export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
export RUSTFLAGS="-C opt-level=2 -C target-cpu=haswell"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"