summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2024-04-11 16:37:13 +0200
committerFélix Piédallu2024-04-11 16:51:05 +0200
commitf154907677155b4fee4ae499e8e8572be2d97fc4 (patch)
tree1d7741b7902d324090f7a7f3c2e8439c1f7772f2
parent92cbd19a9e130a77eaeb0bd4d66287003f8a5cee (diff)
downloadaur-prusa-slicer-git.tar.gz
Bump pkgver, reduce diff with repo package
Fix build: remove old cherry-pick, add new patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--fix_num_constrexpr.patch12
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e1677d44037..ff62f70cbb9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prusa-slicer-git
- pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
- pkgver = 2.6.0.beta4.r1.gdbc2584d8
+ pkgdesc = G-code generator for 3D printers (Prusa fork of Slic3r) (git version)
+ pkgver = 2.7.4
pkgrel = 1
url = https://github.com/prusa3d/PrusaSlicer
arch = i686
@@ -19,6 +19,8 @@ pkgbase = prusa-slicer-git
depends = intel-tbb
conflicts = prusa-slicer
source = git+https://github.com/prusa3d/PrusaSlicer
+ source = fix_num_constrexpr.patch
sha256sums = SKIP
+ sha256sums = 91d198af5eecaf6d1a71ad8b59f03e4fa7cefb02c714b3a26978ac8772f8296e
pkgname = prusa-slicer-git
diff --git a/PKGBUILD b/PKGBUILD
index c20c02f025f3..212ef78a8386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Salamandar <felix@piedallu.me>
pkgname=prusa-slicer-git
-pkgver=2.6.0.beta4.r1.gdbc2584d8
+pkgver=2.7.4
pkgrel=1
-pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
+pkgdesc="G-code generator for 3D printers (Prusa fork of Slic3r) (git version)"
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
-url='https://github.com/prusa3d/PrusaSlicer'
+url="https://github.com/prusa3d/PrusaSlicer"
license=('AGPL3')
makedepends=(
'git'
@@ -35,9 +35,11 @@ depends=(
source=(
"git+${url}"
+ "fix_num_constrexpr.patch"
)
sha256sums=(
'SKIP'
+ '91d198af5eecaf6d1a71ad8b59f03e4fa7cefb02c714b3a26978ac8772f8296e'
)
conflicts=('prusa-slicer')
@@ -48,8 +50,8 @@ pkgver() {
prepare() {
cd "PrusaSlicer"
- # Repair gcc13 build
- git cherry-pick "72f6a4e7c7dccc47f203ce8c27b3022c6d7743e8"
+ # Repair clang15 build
+ patch --forward --strip=1 --input=../fix_num_constrexpr.patch
rm "$srcdir/PrusaSlicer/cmake/modules/FindEXPAT.cmake"
}
diff --git a/fix_num_constrexpr.patch b/fix_num_constrexpr.patch
new file mode 100644
index 000000000000..4c5b108d10f4
--- /dev/null
+++ b/fix_num_constrexpr.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3b37dbac6..594708cd4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,6 +244,7 @@ if (NOT MSVC AND ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU" OR "${CMAKE_CXX_COMP
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall" )
+ endif ()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-reorder" )
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-enum-constexpr-conversion" )
+
+ # On GCC and Clang, no return from a non-void function is a warning only. Here, we make it an error.
+ add_compile_options(-Werror=return-type)