summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Csiky (csicar)2019-08-11 19:49:16 +0200
committerCarsten Csiky (csicar)2019-08-11 19:49:16 +0200
commitd1c3874b78bb5ce736e6e84c5bd0a468a0162593 (patch)
tree02de57127045cd10f2ccc9ff03393140243a500e
downloadaur-psgo-git.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89bb9cc6f5f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = psgo-git
+ pkgdesc = PureScript Go Compiler
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/andyarvanitis/purescript-native
+ arch = any
+ license = BSD3
+ makedepends = stack
+ depends = go
+ source = https://github.com/andyarvanitis/purescript-native/archive/golang.zip
+ sha256sums = SKIP
+
+pkgname = psgo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e7930f91ddd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: csicar <aur@csicar.de>
+pkgname=psgo-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="PureScript Go Compiler"
+arch=(any)
+url="https://github.com/andyarvanitis/purescript-native"
+license=('BSD3')
+depends=('go')
+optdepends=()
+makedepends=('stack')
+source=('https://github.com/andyarvanitis/purescript-native/archive/golang.zip')
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/purescript-native-golang
+ stack build
+
+}
+
+package() {
+ cd $srcdir/purescript-native-golang
+
+ install -Dm755 .stack-work/dist/*-linux-tinfo6/Cabal-*/build/psgo/psgo "$pkgdir/usr/bin/psgo"
+ install -Dm644 "$srcdir/purescript-native-golang/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: