summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-01-14 01:39:02 +0100
committerChristopher Arndt2021-01-14 01:40:47 +0100
commit3fdb5f5331d66e795926f49a5faca8859d28b985 (patch)
tree01e7adaa4a264edac5a63403401f7141589e9912
downloadaur-psi-plugins.lv2-git.tar.gz
Add new VCS package 'psi-plugins.lv2-git'
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD62
-rw-r--r--psi-plugins-lv2ui-descriptor.diff66
4 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aae5f8df89b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = psi-plugins.lv2-git
+ pkgdesc = A small collection of LV2 plugins ideal for (but not limited to) electronic music (git version)
+ pkgver = 0.0.1.r16.83f318d
+ pkgrel = 1
+ url = https://github.com/ycollet/psi-plugins
+ arch = x86_64
+ groups = lv2-plugins
+ license = GPL2
+ makedepends = git
+ makedepends = lv2
+ makedepends = ntk
+ makedepends = python2
+ provides = psi-plugins.lv2
+ provides = psi-plugins.lv2=0.0.1
+ conflicts = psi-plugins.lv2
+ source = psi-plugins.lv2::git+https://github.com/ycollet/psi-plugins
+ source = psi-plugins-lv2ui-descriptor.diff
+ md5sums = SKIP
+ md5sums = 08eab2c4c57bdb162b4397baad61e39b
+
+pkgname = psi-plugins.lv2-git
+ depends = libntk.so
+ depends = libntk_images.so
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..946aeaed680d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+psi-plugins.lv2/
+psi-plugins.lv2-git-*.pkg.tar.xz
+psi-plugins.lv2-git-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e445a1d953
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name=psi-plugins
+_pkgname="${_name}.lv2"
+pkgname="${_pkgname}-git"
+pkgver=0.0.1.r16.83f318d
+pkgrel=1
+pkgdesc="A small collection of LV2 plugins ideal for (but not limited to) electronic music (git version)"
+arch=('x86_64')
+url="https://github.com/ycollet/psi-plugins"
+license=('GPL2')
+depends=()
+makedepends=('git' 'lv2' 'ntk' 'python2')
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_pkgname}")
+groups=('lv2-plugins')
+source=("${_pkgname}::git+https://github.com/ycollet/psi-plugins"
+ 'psi-plugins-lv2ui-descriptor.diff')
+md5sums=('SKIP'
+ '08eab2c4c57bdb162b4397baad61e39b')
+
+_plugins=(
+ midi_gate-psi
+ midi_rnd-psi
+ sidechain_gate-psi
+ super_welle-psi
+)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ local ver=$(grep '^VERSION' wscript | cut -d "'" -f 2)
+ echo ${ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ patch -p1 -N -i "${srcdir}/psi-plugins-lv2ui-descriptor.diff"
+
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ python2 waf configure --prefix=/usr
+ python2 waf build $MAKEFLAGS
+}
+
+package() {
+ depends=('libntk.so' 'libntk_images.so')
+ cd "${srcdir}/${_pkgname}"
+
+ python2 waf install --destdir="${pkgdir}"
+
+ # Move README.md files out of LV2 bundles into doc dir
+ for plugin in ${_plugins[*]}; do
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/${plugin}.lv2"
+ mv "${pkgdir}/usr/lib/lv2/${plugin}.lv2/README.md" \
+ "${pkgdir}/usr/share/doc/${pkgname}/${plugin}.lv2"
+ done
+}
diff --git a/psi-plugins-lv2ui-descriptor.diff b/psi-plugins-lv2ui-descriptor.diff
new file mode 100644
index 000000000000..8f98dd3181d5
--- /dev/null
+++ b/psi-plugins-lv2ui-descriptor.diff
@@ -0,0 +1,66 @@
+diff --git a/midi_gate-psi.lv2/midi_gate_ui.cxx b/midi_gate-psi.lv2/midi_gate_ui.cxx
+index e0be2d4..c63cf95 100644
+--- a/midi_gate-psi.lv2/midi_gate_ui.cxx
++++ b/midi_gate-psi.lv2/midi_gate_ui.cxx
+@@ -43,7 +43,7 @@ typedef struct {
+ LV2UI_Controller controller;
+ } MidiGateGUI;
+
+-static LV2UI_Handle instantiate(const struct _LV2UI_Descriptor * descriptor,
++static LV2UI_Handle instantiate(const struct LV2UI_Descriptor * descriptor,
+ const char * plugin_uri,
+ const char * bundle_path,
+ LV2UI_Write_Function write_function,
+@@ -158,7 +158,7 @@ static const void* extension_data(const char* uri) {
+ return NULL;
+ }
+
+-static LV2UI_Descriptor descriptors[] = {
++static const LV2UI_Descriptor descriptors[] = {
+ {MIDIGATE_UI_URI, instantiate, cleanup, port_event, extension_data}
+ };
+
+diff --git a/sidechain_gate-psi.lv2/sidechain_gate_ui.cxx b/sidechain_gate-psi.lv2/sidechain_gate_ui.cxx
+index 988555f..878082f 100644
+--- a/sidechain_gate-psi.lv2/sidechain_gate_ui.cxx
++++ b/sidechain_gate-psi.lv2/sidechain_gate_ui.cxx
+@@ -37,7 +37,7 @@ typedef struct {
+ LV2UI_Controller controller;
+ } SidechainGateGUI;
+
+-static LV2UI_Handle instantiate(const struct _LV2UI_Descriptor * descriptor,
++static LV2UI_Handle instantiate(const struct LV2UI_Descriptor * descriptor,
+ const char * plugin_uri,
+ const char * bundle_path,
+ LV2UI_Write_Function write_function,
+@@ -187,7 +187,7 @@ static const void* extension_data(const char* uri) {
+ return NULL;
+ }
+
+-static LV2UI_Descriptor descriptors[] = {
++static const LV2UI_Descriptor descriptors[] = {
+ {SCGATE_UI_URI, instantiate, cleanup, port_event, extension_data}
+ };
+
+diff --git a/super_welle.lv2/super_welle_ui.cxx b/super_welle.lv2/super_welle_ui.cxx
+index aee9703..c5c3b7a 100644
+--- a/super_welle.lv2/super_welle_ui.cxx
++++ b/super_welle.lv2/super_welle_ui.cxx
+@@ -55,7 +55,7 @@ typedef struct {
+
+ uint8_t update_ui = 0;
+
+-static LV2UI_Handle instantiate(const struct _LV2UI_Descriptor * descriptor,
++static LV2UI_Handle instantiate(const struct LV2UI_Descriptor * descriptor,
+ const char * plugin_uri,
+ const char * bundle_path,
+ LV2UI_Write_Function write_function,
+@@ -748,7 +748,7 @@ static const void* extension_data(const char* uri) {
+ return NULL;
+ }
+
+-static LV2UI_Descriptor descriptors[] = {
++static const LV2UI_Descriptor descriptors[] = {
+ {SW_UI_URI, instantiate, cleanup, port_event, extension_data}
+ };
+