summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2018-11-09 02:22:52 +0100
committerpiotr2018-11-09 02:22:52 +0100
commit345ec2ee4cf582fd906bce1be0adad7df928682f (patch)
treecd9312c19268cf71cad011fa65e4ac4708e4f538
downloadaur-345ec2ee4cf582fd906bce1be0adad7df928682f.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58498bae9ad8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = psuinfo
+ pkgdesc = A psutil-based command to display customizable system usage info in a single line, intended for Tint2 executors or CLI
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/nwg-piotr/psuinfo
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = python-psutil
+ source = https://github.com/nwg-piotr/psuinfo/raw/master/psuinfo
+ md5sums = 59ea520db64b5a9711e9a3fbd815ac98
+
+pkgname = psuinfo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ebc5a91134a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+pkgname=('psuinfo')
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A psutil-based command to display customizable system usage info in a single line, intended for Tint2 executors or CLI"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/psuinfo"
+license=('GPL3')
+depends=('python' 'python-psutil')
+
+source=(https://github.com/nwg-piotr/psuinfo/raw/master/psuinfo)
+
+md5sums=('59ea520db64b5a9711e9a3fbd815ac98')
+
+package() {
+ install -D -m 755 psuinfo \
+ "$pkgdir"/usr/bin/psuinfo
+}
+