summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-10-07 09:46:39 -0300
committerDaniel Bermond2023-10-07 09:46:39 -0300
commit8e7ca2d6655d87266a99c3fe3c1a73990fcbe050 (patch)
treeed4b801f4a78eda9ce67124c9edbe47e6b9aa8c3
parent5dcdcb30a708aca6951e57197703b4da7449a7e0 (diff)
downloadaur-pthreadpool-git.tar.gz
Match latest upstream changes. Update desc, arch and cmake cmds.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD47
2 files changed, 23 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09979606906b..2745cb20ddb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = pthreadpool-git
- pkgdesc = A pthread-based thread pool implementation for C/C++ (git version)
- pkgver = r56.6673a4c
- pkgrel = 2
+ pkgdesc = A portable thread pool implementation for C/C++ (git version)
+ pkgver = 0.1.r144.g4fe0e1e
+ pkgrel = 1
url = https://github.com/Maratyszcza/pthreadpool/
- arch = i386
arch = x86_64
license = BSD
makedepends = git
@@ -14,7 +13,8 @@ pkgbase = pthreadpool-git
provides = pthreadpool
conflicts = pthreadpool
source = git+https://github.com/Maratyszcza/pthreadpool.git
+ source = git+https://github.com/Maratyszcza/FXdiv.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = pthreadpool-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7564b006f9a0..ca28e0cb5a47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,43 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: <dbermond@archlinux.org>
pkgname=pthreadpool-git
-pkgver=r56.6673a4c
-pkgrel=2
-pkgdesc='A pthread-based thread pool implementation for C/C++ (git version)'
-arch=('i386' 'x86_64')
+pkgver=0.1.r144.g4fe0e1e
+pkgrel=1
+pkgdesc='A portable thread pool implementation for C/C++ (git version)'
+arch=('x86_64')
url='https://github.com/Maratyszcza/pthreadpool/'
license=('BSD')
depends=('glibc')
makedepends=('git' 'cmake' 'python' 'gtest')
provides=('pthreadpool')
conflicts=('pthreadpool')
-source=('git+https://github.com/Maratyszcza/pthreadpool.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/Maratyszcza/pthreadpool.git'
+ 'git+https://github.com/Maratyszcza/FXdiv.git')
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd pthreadpool
-
- # git, no tags available
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C pthreadpool describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd pthreadpool
-
- cmake \
- -DBUILD_GMOCK:BOOL='OFF' \
- -DBUILD_GTEST:BOOL='OFF' \
+ cmake -B build -S pthreadpool \
-DBUILD_SHARED_LIBS:BOOL='ON' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DPTHREADPOOL_BUILD_BENCHMARKS:BOOL='OFF' \
- -Wno-dev \
- .
- make
+ -DFXDIV_SOURCE_DIR:STRING="${srcdir}/FXdiv" \
+ -DGOOGLETEST_SOURCE_DIR:STRING='/usr/src/googletest' \
+ -Wno-dev
+ cmake --build build
}
check() {
- cd pthreadpool
-
- make test
+ ctest --test-dir build --output-on-failure
}
package() {
- cd pthreadpool
-
- make DESTDIR="$pkgdir" install
-
+ DESTDIR="$pkgdir" cmake --install build
rm "${pkgdir}/usr/include/fxdiv.h"
-
- # license
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 pthreadpool/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}